2

LaTeX changed position of dot, why?

please see the below example

to the third dimension\cite{Ref13}. 

and the result:

enter image description here

The dot was supposed to be on the right of the footnote.

Some important parts of my Latex file:

\documentclass[12pt]{spieman}  % 12pt font required by SPIE;

%\documentclass[a4paper,12pt]{spieman}  % use this instead for A4 paper

\usepackage{amsmath,amsfonts,amssymb}

\usepackage{graphicx}

\usepackage{setspace}

\usepackage{tocloft}

\usepackage{lineno}

\usepackage{xcolor, soul}

\sethlcolor{green}

\usepackage{subcaption}

\usepackage{cleveref}



%%%%% References %%%%%

\bibliography{report}   % bibliography data in report.bib

\bibliographystyle{spiejour}   % makes bibtex use spiejour.bst


\vspace{1ex}

\noindent Biographies and photographs of the other authors are not available.

\end{spacing}

\end{document}
9
  • 10
    some cite commands are clever and implement the style that the citation should be after punctuations. As you didn't gave a complete example, I can't tell you how to avoid it. – Ulrike Fischer Dec 30 '20 at 18:42
  • 4
    Welcome to TeX.SX! In order to help you, we need to see as small complete document, starting with \documentclass and ending with \end{document} that shows the described behaviour. At the left bottom corner, click on the edit button and add the source code. – gernot Dec 30 '20 at 19:07
  • 2
    As Ulrike and gernot already mentioned, a question like this can only reasonably be answered if we know how you produce your citations (i.e. which citation/bibliography packages are involved). This is best shown in a short example document, often called MWE - short for minimal working example - that reproduces the output you show in the question with as little preamble and body code as possible, while still being compilable for everyone who doesn't have your files. tex.meta.stackexchange.com/q/228/35864 and tex.meta.stackexchange.com/q/4407/35864 explain more details. – moewe Dec 31 '20 at 8:22
  • 1
    The code shown so far is not compilable: It is missing a \begin{document} and appears to consist only of two separate code snippets. We also don't have your .bib file. I could not find the document class you are using spieman on CTAN, so please also tell us where we can find it (a link to the source where you got it would be best, so we can be sure we are talking about the same file). Please read tex.meta.stackexchange.com/q/228/35864 for more help on creating MWEs. – moewe Jan 1 at 17:34
  • 1
    If that's how the journal's template does it, then you don't want to change it. – Teepeemm Jan 1 at 17:44
1

It looks like a deliberate design decision: the class spieman.cls does \RequirePackage[super]{cite}. The package cite describes this behavior for the \cite command with the super option.

trailing punctuation is moved to come before the superscript citation

It also says

You may disable movement with the [nomove] package option.

The authors of spieman.cls decided not to do that so I can only repeat: this looks like a deliberate design decision.

Anyway, in order to prevent the behavior (and in order to avoid the option clash error) one needs to do either

\PassOptionsToPackage{nomove}{cite}

or

\RequirePackage[super,nomove]{cite}

before \documentclass{spieman}:

\PassOptionsToPackage{nomove}{cite}
\documentclass[12pt]{spieman}

\begin{document}

to the third dimension\cite{Alred03}.

\bibliography{report}
\bibliographystyle{spiejour}

\end{document}

enter image description here

1
  • Thank you very much – masoumeh Jan 2 at 4:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.