2

I have an equation with a sum in it that is written in displayed mode. I would like the limits of my sum to appear on the right. However, when I write it, it appears with the limits below the sum. My code and its output are given below:

\[f(x) = \sum_{y\in X} g(x) 

enter image description here

I'm sure there's an easy fix for this, but I'm at a dead end. Thank you!

1
  • Welcome to the TeX.SE. – Sebastiano Dec 31 '20 at 19:28
7

Using \nolimits, having this output?

enter image description here

\documentclass[a4paper,12pt]{article}
\usepackage{amsmath,amssymb}


\begin{document}
\[f(x) = \sum\nolimits_{x\in X} g(x) \]
\end{document}

If your style dictates that all limits for big operators should go on the right, you can use the global option nosumlimits:

\documentclass[a4paper,12pt]{article}
\usepackage[nosumlimits]{amsmath}
\usepackage{amssymb}


\begin{document}

\[f(x) = \sum_{x\in X} g(x) \qquad \bigcup_{x\in X}A_x=A\]

\end{document}

enter image description here

4
  • 1
    You were faster than me! (+1).Happy new year! – Bernard Dec 31 '20 at 19:29
  • @Bernard I'm going to reciprocate now ahahah. – Sebastiano Dec 31 '20 at 19:29
  • 2
    And, if the style requires this for every summation symbol, it's easier to call \usepackage[nosumlimits]{amsmath} – egreg Dec 31 '20 at 22:02
  • @egreg I'm not expert on this topic :-( It is the first time that I see this option....Please, can you edit my answer because the comment it is your. I wish you and all the user a BEST NEW YEAR and I hope also for me. I hope so much but my wishes never come true :-( – Sebastiano Dec 31 '20 at 22:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.