3

I tried to follow this answer from 3 years ago which suggests the following command:

\setlength{\metropolis@progressinheadfoot@linewidth}{2.5pt}

However, when I run this command, I get the following three errors.

Undefined control sequence. [...polis@progressinheadfoot@linewidth}{2.5pt}] 
Missing number, treated as zero. [] 
Illegal unit of measure (pt inserted). []

I also get these errors when I compile the presentation in overleaf, so I don't think this is something about my particular mactex setup. I am able to change the color of the progress bar, and without the inclusion of that command my beamer presentation compiles correctly. I checked the style files for metropolis on my computer, and the outer theme does use the setting

\setlength{\metropolis@progressinheadfoot@linewidth}{0.4pt}

If I change the style file itself, I am able to get the desired effect, but obviously, it would be nice to set this option in the document as opposed to modifying the underlying style files.

Any ideas on how to do this? Thanks for your help!

Here is a minimal example to reproduce the error:

\documentclass[12pt]{beamer}

\usetheme[progressbar=frametitle]{metropolis}
\usepackage{appendixnumberbeamer}
\usepackage{booktabs}
\usepackage[scale=2]{ccicons}

% Change Colors/Width of Progress Bars 
\setlength{\metropolis@progressinheadfoot@linewidth}{2.5 pt}


\title{Title}
\author{Author}

\begin{document}

\maketitle
\section{Introduction}

\begin{frame}{Context}
\begin{itemize}
    \item example text
    \item example text
\end{itemize}
\end{frame}

\end{document}

1 Answer 1

7

I was missing the command \makeatletter:

\makeatletter
\setlength{\metropolis@titleseparator@linewidth}{2pt}
\setlength{\metropolis@progressonsectionpage@linewidth}{2pt}
\setlength{\metropolis@progressinheadfoot@linewidth}{2pt}
\makeatother
1
  • 3
    Thank you!! I looked for this answer for years!
    – Jacob
    Jan 16, 2022 at 17:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .