I am having problems with citations that are correctly being assigned a number in my text now showing up in my bibliography. I am using biblatex with biber and texmaker as my editor.

Latex code:





First cite \cite{murata1980reduction}.

Second cite \cite{godefroid1993refining}.

Third cite \cite{cudd}.



    title = {{Reduction and Expansion of Live and Safe Marked Graphs}},
    author = {T. Murata and J. Koh},
    journal = {IEEE Transactions on Circuits and Systems},
    pages = {68-71},
    year = {1980},
    volume = {27},
    number= {1},
    note =  {IEEE},
    doi = {10.1109/TCS.1980.1084711}

    title = {{Refining Dependencies Improves Partial-Order Verification Methods (Extended Abstract)}},
    author = {P. Godefroid},
    booktitle = {Computer Aided Verification},
    year = {1993},
    series = {LNCS},
    volume = {697},
    publisher = {Springer Berlin Heidelberg},
    pages = {438-449},
    doi = {10.1007/3-540-56922-7_36}

  title = {{CUDD: CU Decision Diagram Package}},
  author = {F. Somenzi},
  howpublished = {\url{http://web.mit.edu/sage/export/tmp/y/usr/share/doc/polybori/cudd/cuddIntro.html}}

Compilation result in the following result:

enter image description here

I have noticed that references using the article entry works fine, but misc and inproceedings does not. How do I make them appear in my bibliography? There are no helpful compilation warnings as far as I can tell.

  • 2
    You have type=article in your \printbibliography...
    – cgnieder
    Jan 4 at 22:03
  • Yes, that was the issue. My question can be disregarded completely.
    – Fred
    Jan 4 at 22:14
  • @cgnieder Do you want to type up an answer, or do you want us to close the question as simple typo/misunderstanding?
    – moewe
    Jan 5 at 8:14

You are filtering your references by having type=article as argument to \printbibliography. Quoting the biblatex manual (v3.16 p. 91):


Print only entries whose entry type is <entrytype>.


Print only entries whose entry type is not <entrytype>. This option may be used multiple times.

Just remove it and you should be fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.