2

As far as I understand, the plain bibliography style in BibTex should display the school name when citing a Phd Thesis. However I can neither get the school name nor the URL to show.

Here is the MWE:

\documentclass[a4paper,reqno,10pt]{amsart}

% packages:
\usepackage[USenglish]{babel}

\usepackage{amsrefs}    
\usepackage{url}



\begin{document}
Item to cite: \cite{ABC}.

\bibliographystyle{plain}
\bibliography{References}
\end{document}

My bib file contains the following entry:

@PhdThesis{ABC,
  author = {John Doe},
  title  = {{Title of thesis}},
  school = {Institution name},
  year   = {2021},
  url   = {https://tex.stackexchange.com},
  language  = {English}
}

Here's a screenshot of the output: Here's a screenshot of the output

How do I get the school name and URL to show without changing the bibliography style? I know that I can just add a "note" field but the issue with that is that the "language" field is printed first, while school name should ideally be printed after "Ph.D. Thesis".

4
  • 1
    \usepackage{amsrefs} forces a different \bibliographystyle than they one you set in your document. It effectively makes \bibliographystyle do nothing, so your \bibliographystyle{plain} has no effect at all and you are not actually using BibTeX's plain style. If you want to use normal BibTeX, remove \usepackage{amsrefs}.
    – moewe
    Jan 5, 2021 at 12:38
  • @moewe I see. That solved my problem. However, now the "language" field is omitted from all the entries. I guess the "plain" style ignores it? Is there a way around this other than using the "note" field? Jan 5, 2021 at 12:50
  • Indeed, plain does not know a language field. If the information is required, you can use note - or you could use a different style.
    – moewe
    Jan 5, 2021 at 13:05
  • @moewe Alright. Thank you! Jan 5, 2021 at 13:08

1 Answer 1

2

The plain bibliography style is so very old that it actually predates the creation of the Internet, the WWW, and URLs. As such, plain doesn't know the url field name; fields with unknown names are ignored by BibTeX.

I suggest you load the natbib citation management package with the option numbers and employ the plainnat bibliography style instead of the plain style. The plainnat style does not ignore url fields.

The plainnat bib style doesn't process the language field. If you believe that it's essential to inform your readers that the document is in English, just change language = {English} to note = {Language: English}. (Personally, I wouldn't bother unless it's somehow essential to indicate the document's main language.)

enter image description here

\documentclass[a4paper,reqno,10pt]{amsart}
\begin{filecontents}[overwrite]{References.bib}
@PhdThesis {ABC,
  author = {John Doe},
  title  = {{Title of thesis}},
  school = {Institution name},
  year   = {2021},
  url    = {https://tex.stackexchange.com},
  note   = {Language: English}
}
\end{filecontents}

\usepackage[english]{babel}  
\usepackage[numbers]{natbib}
\usepackage{xurl} % or 'url'

\begin{document}
\cite{ABC}
\bibliographystyle{plainnat}
\bibliography{References}
\end{document}
2
  • Would you recommend plainnat over plainurl? Jan 5, 2021 at 14:04
  • @SahibaArora - I'm afraid I'm not at all familiar with the plainurl bib style.
    – Mico
    Jan 5, 2021 at 14:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .