2

Just like here Inkscape produces a pdf_tex file that contains higher page numbers then the generated PDF contains. Deleting the line in question in the file fixes the issue. User Martin Schröder recommended in the comments to open new questions on here if this issue should reoccure with newer inksacpe versions. I created the svg file initially with an inkscape version that still had the error and since upgraded to 1.0.1 (3bc2e813f5, 2020-09-07). Please find my files that exhibit the problem here.

This is the relevant part of the logfile:

(/compile/cable-turned-labeled.pdf_tex
<cable-turned-labeled.pdf, id=1, page=1, 435.84906pt x 438.56055pt>
File: cable-turned-labeled.pdf Graphic file (type pdf)
<use cable-turned-labeled.pdf, page 1>
Package pdftex.def Info: cable-turned-labeled.pdf , page1 used on input line 56
.
(pdftex.def)             Requested size: 165.59853pt x 166.62796pt.
LaTeX Font Info:    External font `cmex10' loaded for size
(Font)              <9> on input line 57.
LaTeX Font Info:    External font `cmex10' loaded for size
(Font)              <5> on input line 57.

!pdfTeX error: pdflatex (file /compile/cable-turned-labeled.pdf): PDF inclusion
: required page does not exist <1>
 ==> Fatal error occurred, no output PDF file produced!

I already moved everything into the topmost layer in inkscape, but the problem persists. It turns out to be very tidious to manually edit the pdf_tex file(s). What further work arounds are there? I work in Overleaf (and Windows as a local OS), so I cant even use a Makefile to automatically remove the bogous lines from the file. What other options do I have?

2
2

Maybe you could give package svg a try.

\listfiles
\documentclass{minimal}
\usepackage[T1]{fontenc}
\usepackage{svg}
\begin{document}
\noindent\includesvg[width=\textwidth,inkscapearea=page]{cable-turned-labeled}%
\end{document}

Disclaimer: I am the author of package svg

2
  • thank you! does that work on overleaf? – Andreas Schuldei Jan 8 at 8:55
  • yes, works as advertised, also on overleaf. problem solved. – Andreas Schuldei Jan 8 at 9:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.