0

I'm using latexmk (calling xelatex with pdfxe) and have a makefile around it, that calls the externalised makefile from tikz/pgf. The code worked fine list year (last time compiled June-2020). Meanwhile I've updated my operating system to Mac OS Big Sur, tex live and all packages, ran the fmtutil scripts, ...

I have three documents, compiling with the same setup:

  • a test document: works fine
  • the presentation material for one course, I'm teaching: works fine
  • the presentation material for another course, I'm teaching: crashes

For the one that crashes: I am including about 250 externalized tikz-pictures (total size about 13 MB) into the main document (total size about 4.5 MB).

For the one that works: the final output file size is about 5.6 MB. The size of the included figures is about 3.6 MB.

So I started commenting code in the one that crashes: no success.

The error I'm getting is:

xdvipdfmx zsh: segmentation fault
xdvipdfmx: Command for 'xdvipdfmx' gave return code 11

I've now invested about 48 hours in commenting various parts of the material: it does not depend on the size or a specific line, but it is reproducible. E.g. at some point it crashed at a certain chapter. Commenting it, removed the error. Then adding everting but the heading: worked. Adding the heading afterwards: works. Including the next chapter (contents): crashes on the first run; ignoring this and adding one more chapter: works on the second run. This is reproducible after restarting the computer. 😬🤔 I've checked for cross section links and unresolved labels: all commented.

Questions:

  • Generic: Can anyone point me in a good direction?
  • More specific: why is xdvipdfmx involved at all, if I call latexmk with the option -pdfxe?
  • what updates might have been made to such an installation since mid 2020 until beginning 2021? (I've reverted to latexmk 4.67, as I've seen the mods on calling xdvipdfmk with the flag -E since September 2020. That was not it.) Anything similar, that I've missed?

Thanks in advance 🙏

UPDATE 1:

I now ran tlmgr restore -all and afterwards had to update amsmath. So basically I reverted my tex installation back to the days, when I still could compile my code. This seems to have eliminated the issue.

So next step is to find out, which of the many many reverted packages could have caused the issue. Hot candidates are the ones, which I'm only using in the document that crashes, but not in the others. Here's the list of potential suspects:

\usepgfplotslibrary{groupplots}
\usepackage{stmaryrd}
\usepackage{toolbox}
\usepackage{txfonts}
\usepackage{multicol}
\usepackage{amsmath}
\usepackage{mathtools}
\usetikzlibrary{arrows.meta}
\usetikzlibrary{fadings}
\usetikzlibrary{patterns}
\usepackage{tikz-3dplot}

I'll be digging deeper to figure out which package exactly caused the trouble, but as I did not change the way I'm invoking latexmk from my Makefile, I now can exclude latexmk to be the sinner.

UPDATE 2:

When compiling with the latest and greatest version of packages (2020-01-08), I have seen this error multiple times in the log file

Missing character: There is no 3 in font nullfont!

with various numbers, where 3 is only an example here. xdvipdfmx runs fine with only few of them, but for now I believe, I have seen warnings/errors from xdvipdfmx only, when xelatex produced the Missing character warning. It appears to me, that this is something very old popping up again after an update of some package. While my first intuition points towards tikz, I cannot help but puzzling about the fact that I could reproduce/remove the error by simply adding removing a subsubsection command. I tried with and without the corresponding label (as I thought this to be a common denominator between my a tikzpicture and a subsubsection, but the label command made no difference). So if anyone is on to the all-of-a-sudden-popping-up again Missing character issue running xelatex, this might or might not be related. Degugging this takes time, but I'll keep you posted.

7
  • 1
    xdvipdfmx is involved as xelatex basically runs first xelatex --no-pdf to create a xdv and then calls xdvipdfmx to convert this xdv to a pdf. Try to split this too, if this also crashes, you could use xdvipdfmx -vv file to get more info. Jan 8 '21 at 19:00
  • Thanks @UlrikeFischer: according to personal.psu.edu/~jcc8/software/latexmk/latexmk-470b.txt the option -pdfxe for latexmk should directly make the pdf. takes longer time, but should about calling xdvipdfmx. Even I use this option, xdvipdfmx is getting called anyways. Hmmm?!?
    – aknott
    Jan 8 '21 at 19:12
  • 1
    Xdvipdfmx is always used by xelatex. Jan 8 '21 at 19:18
  • 1
    To reinforce @UlrikeFischer's point, there's a useful addition I should make to the description of the -pdfxe option in the latexmk documentation. This is just to mention that if xelatex is invoked without the -no-pdf option, then internally it still invokes xdvipdfmx. Jan 8 '21 at 20:35
  • For debugging this problem: 1. Is there anything that looks significant in latexmk's output between where it starts running xdvipdfmx and the error message quoted in the question? 2. What happens if you run xelatex from the command line without the -no-pdf option? 3. Ditto if you give it the -no-pdf option and then invoke xdvipdfmx on the xdv file? Jan 8 '21 at 20:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.