0

Background: I have got MiKTeX portable running on a sealed-off enterprise Windows computer (no admin rights, Symantec Endpoint Protection, tons of group policies, Zscaler, constant background administration trough running PowerShell actions and the like...). Lately I realized that when I compile a document the Latex log file is discarded (obviously all files with suffix *.log). I haven't found the process responsible for that, but I suspect the paranoia of the company in broader sense.

Question: Is there a way to re-direct the log file creation to another file (with a more harmless suffix like *.txt) during compilation?

6
  • Guess: Maybe redirect the output on the cmd console to a text file. Commented Jan 13, 2021 at 7:40
  • @Dr.ManuelKuehner: do you have an example?
    – tfran
    Commented Jan 13, 2021 at 7:46
  • unless you are using a modified binary I think the log must be written somewhere. are you sure it is not being written to a separate folder due to output-directory or similar command line options? Commented Jan 13, 2021 at 8:18
  • @DavidCarlisle : I'm sure the log file is created in the same directory as the tex source files are in. I tested it on another (private) computer. It is a kind of "post-processing" step that the log files is erased.
    – tfran
    Commented Jan 13, 2021 at 8:56
  • then can you not simply run pdflatex myfile; move myfile.log myfile.wibble as your commandline? Commented Jan 13, 2021 at 9:17

1 Answer 1

1

Folks, my sincere apologies, it is just embarrasing. I messed up my settings on the PC: the $PATH (environment variable for MikTEX ) was set up incorrectly. The log files were just created in a different directory. I am sorry if I have wasted your valuable time.

3
  • Exactly how can a PATH variable change where the logs end up? Could you elaborate on that?
    – daleif
    Commented Jan 13, 2021 at 10:48
  • PATH setting would make miktex not run it would not make it write the log file to a different place. Glad you got it working but I suggest you delete question and answer as they are not likely to help others. Commented Jan 13, 2021 at 19:01
  • I am not allowed to delete my question.anymore. I added directory e:\miktex-portable\texmfs\install\bin\x64 to the environment variables and this was the place were pdf and log was created when i started pdflatex
    – tfran
    Commented Jan 13, 2021 at 20:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .