0

So im trying to get started using overleaf as its recommended on one of my courses, but for some reason Overleafs VIM mode is not detecting the escape key properly. Im on Ubuntu 20.04 and ive swapped escape and caps lock using setxkbmap -option caps:swapescape. But if im in Overleaf insert mode, pressing caps lock does not return me to Normal mode. Only way to go back to normal mode is by pressing the esc key, which also toggles caps lock on. Its very frustrating and not usable.

Any ideas what I could do to fix it?

0

Why not use

:nmap jj <Esc>

To escape to normal mode by pressing j twice.

  • not what im looking for – Saippua Jan 13 at 13:55
  • Questions like this are best sent to Overleaf support (support@overleaf.com). I'm on the Overleaf support team, and we're happy to answer these kinds of questions. Briefly: Overleaf won't detect settings you've configured via setxkbmap. The vim and emacs keybindings are a more limited emulation of those, and are provided via an open source library (currently ace.c9.io). – Dan MacKinnon Jan 13 at 19:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.