1

My university has its own kind of Harvard referencing that requires first initial as well as surname, im struggling to find out how to insert this using biblatex. my current code for referencing is:

\usepackage[english]{babel}
\usepackage[firstinits=true,style=authoryear-comp,backend=biber]{biblatex}
\renewcommand*{\nameyeardelim}{\addcomma\space}

\addbibresource{sample.bib}% Syntax for version >= 1.2

From bibliography file:

@article{Chen2017,
   author = {Chen, Hui and Manso, Gustavo},
   title = {Macroeconomic Risk and Debt Overhang*},
   journal = {The Review of Corporate Finance Studies},
   volume = {6},
   number = {1},
   pages = {1-38},
   ISSN = {2046-9128
2046-9136},
   DOI = {10.1093/rcfs/cfw007},
   year = {2017},
   type = {Journal Article}
}

I'm using \parenthcite{<key>} to cite my sources

according to previous answers on here, including 'firstinits=true' should render the initial into my citation command, but thats not happening.

Any help would be appreciated.

1 Answer 1

1

The option firstinits, which was renamed to giveninits a few years ago now, only changes the name formatting from showing full given names to given name initials. Where biblatex did not show any given names to start with the option has no effect.

By default biblatex's authoryear-based citation styles will only print given names or given name initials in citations to resolve ambiguities due to non-unique family names (if you cite Jane Smith and Anne Smith, biblatex would use J. Smith and A. Smith, so your readers can immediately tell that the authors are different). This feature is controlled by the uniquename option.

If you want given name initials in all citations and full given names to resolve ambiguities (Jane Smith and John Smith), you can redefine the labelname field format. (The original definition can be found in biblatex.def, ll. 955-981 in v3.16)

\documentclass[english]{article}
\usepackage[T1]{fontenc}
\usepackage{babel}
\usepackage{csquotes}

\usepackage[backend=biber, style=authoryear-comp]{biblatex}
\DeclareDelimFormat{nameyeardelim}{\addcomma\space}

\DeclareNameFormat{labelname}{%
  \ifnum\value{uniquename}<2
    \ifuseprefix
      {\usebibmacro{name:given-family}
        {\namepartfamily}
        {\namepartgiveni}
        {\namepartprefix}
        {\namepartsuffixi}}
      {\usebibmacro{name:given-family}
        {\namepartfamily}
        {\namepartgiveni}
        {\namepartprefixi}
        {\namepartsuffixi}}%
  \else
    \usebibmacro{name:given-family}
      {\namepartfamily}
      {\namepartgiven}
      {\namepartprefix}
      {\namepartsuffix}%
  \fi
  \usebibmacro{name:andothers}}

\addbibresource{biblatex-examples.bib}

\begin{document}
Lorem \autocite{sigfridsson}

\printbibliography
\end{document}

Lorem (E. Sigfridsson and U. Ryde, 1998)

2
  • Brilliant, this works perfectly thank you!
    – boovey
    Jan 15, 2021 at 11:17
  • @boovey If the post helped answer your question, please consider accepting the answer to mark the problem as resolved, see tex.stackexchange.com/help/someone-answers.
    – moewe
    Jan 15, 2021 at 13:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .