2

I'm citing a work with biblatex-chicago notes style, and the editor label appears before the translator. I would like it the other way around since this is how this work is cited other places, and the translation was the more notable work in this case (from Latin to English).

Here's my .bib entry:

@book{syntagma3,
title={Syntagma Musicum III},
author={Michael Praetorius},
publisher={Oxford University Press},
location={Oxford},
date={2004},
%origdate={1619},
translator={Kite-Powell, Jeffery T.},
editor={Kite-Powell, Jeffery T.},
keywords={Primary}
}

I get this:

Praetorius, Michael. Syntagma Musicum III. Edited and translated by Jeffery T. Kite-Powell. Oxford: Oxford University Press, 2004.

but I want this:

Praetorius, Michael. Syntagma Musicum III. Translated and edited by Jeffery T. Kite-Powell. Oxford: Oxford University Press, 2004.

I would like that order in citations as well. How can I achieve this?

2 Answers 2

3

One possibility is to switch to the windycity style. This is a newer Chicago style and seems to offer better flexibility and adherence to CMOS than biblatex-chicago.

The option swaptrans does what you want. From the manual:

swaptrans=true, false                 default: false

According to CMOS, if a work has an editor and a translator, their names should appear in citations in the order in which they appear on the work’s title page (see CMOS 14.104). By default, the style lists editors first. Entries with the option swaptrans reverse this order: Their translators print first. If a work’s translators and editors are the same, swaptrans reverses the order of their roles, say, from edited and translated by to translated and edited by. The same goes for compilers, revisers, and updaters, which the style treats as specialized editors. For more information, see section 3.2.

MWE

\documentclass{article}

\begin{filecontents}[overwrite]{\jobname.bib}
@book{syntagma3,
  title={Syntagma Musicum III},
  author={Michael Praetorius},
  publisher={Oxford University Press},
  location={Oxford},
  date={2004},
  %origdate={1619},
  translator={Kite-Powell, Jeffery T.},
  editor={Kite-Powell, Jeffery T.},
  options={swaptrans},
  keywords={Primary}
}
\end{filecontents}

\usepackage[style=windycity]{biblatex}
\addbibresource{\jobname.bib}

\begin{document}
\null\vfill
Filler text \autocite{syntagma3}.
\printbibliography
\end{document}

output

2
  • Thanks! That does indeed accomplish what I wanted. There are some other differences between these two styles that I will have to try to solve now (in shorthand entries of the same source, it lists the title each time instead of just the author, and some of the entries are out of order for chapters in books). Thanks for your help.
    – Jon Arnold
    Commented Jan 29, 2021 at 22:02
  • Found the short short option for the first problem
    – Jon Arnold
    Commented Jan 29, 2021 at 22:06
1

David Fussner, the creator of biblatex-chicago, was able to help me add some custom bibliography strings and create a custom editor type to solve my problem.

This is preferable because windycity does not support listing multiple editors, which I needed for another source.

Here's the MWE:

\documentclass{article}

\begin{filecontents}[overwrite]{\jobname.bib}
@book{syntagma3,
  title={Syntagma Musicum III},
  author={Michael Praetorius},
  publisher={Oxford University Press},
  location={Oxford},
  date={2004},
  %origdate={1619},
  editor={Kite-Powell, Jeffery T.},
  editortype={trev},
  keywords={Primary}
}
\end{filecontents}

\usepackage[notes,backend=biber]{biblatex-chicago}
\addbibresource{\jobname.bib}

\NewBibliographyString{bytrev,cbytrev}
\DefineBibliographyStrings{english}{%
  bytrev = {translated and revised by},%
  cbytrev = {trans\adddotspace and rev\adddot},}

\begin{document}
\null\vfill
Filler text \autocite{syntagma3}.
\printbibliography
\end{document}
1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .