1

I'm trying to use the following journal's Template and I got errors "Undefined control sequence" for any added section. They have included two Tex files and none of them worked for me. Some suggest to update MiKTex and I did. Other suggest to change the class file, which is not allowed by the journal. Another suggestion is to override commands from Tex file. Here, I'm including MWE, however, the class and other files in the link above.

MWE: jcs_template.tex

% PLEASE USE THIS FILE AS A TEMPLATE
% Check file iosart2x.tex for more examples

% add. options: [seceqn,secthm,crcready,onecolumn]
\documentclass[jcs]{iosart2x}

\usepackage{dcolumn}
\usepackage{endnotes}


%% Definitions
\newcolumntype{d}[1]{D{.}{.}{#1}}

\firstpage{1}
\lastpage{5}
\volume{1}
\pubyear{2016}
\begin{document}

\begin{frontmatter}

%\pretitle{}
\title{Article title}
\runtitle{Running head title}
%\subtitle{}

% Two or more authors:
\author[A]{\inits{N.}\fnms{Name1} \snm{Surname1}\ead[label=e1]{first@somewhere.com}%
\thanks{Corresponding author. \printead{e1}.}},
\author[B]{\inits{N.N.}\fnms{Name2 Name2} \snm{Surname2}\ead[label=e2]{second@somewhere.com}}
and
\author[B]{\inits{N.-N.}\fnms{Name3-Name3} \snm{Surname3}\ead[label=e3]{third@somewhere.com}}
\address[A]{Department first, \orgname{University or Company name},
Abbreviate US states, \cny{Country}\printead[presep={\\}]{e1}}
\address[B]{Department first, \orgname{University or Company name},
Abbreviate US states, \cny{Country}\printead[presep={\\}]{e2,e3}}

\begin{abstract}
Abstract text.
\end{abstract}

\begin{keyword}
\kwd{Keyword one}
\kwd{keyword two}
\end{keyword}

\end{frontmatter}

%%%%%%%%%%% The article body starts:

\section{section one}\label{s1}
some text 
\subsection{subsection one}\label{s1.1}

\section{section two}\label{s1}

\begin{table*}[htb]
\caption{Table caption} \label{t1}
\begin{tabular}{ll d{1.3} d{1.3} d{1.3} d{1.3} d{1.3} d{1.3}}
\hline
Dataset&Models&\multicolumn{1}{l}{$\alpha_1$}&
\multicolumn{1}{l}{$\alpha_2$}&
\multicolumn{1}{l}{$\alpha_3$}&
\multicolumn{1}{l}{$\alpha_4$}&
\multicolumn{1}{l}{$\alpha_5$}&
\multicolumn{1}{l}{$\alpha_6$}\\
\hline
CSDS&Linear     &0.164&0.22&0.123&0.3&0.200&0.258\\
& Logistic      &0.189&0.155&0.157&0.201&0.154&0.144\\[6pt]
KCDS&Linear     &0.155&0.183&0.160&0.218&0.176&0.156\\
& Logistic      &0.187&0.125&0.151&0.184&0.187&0.125\\
\hline
\end{tabular}
\end{table*}


\nocite{*} 
% if your bibliography is in bibtex format, use those commands:
\bibliographystyle{ios1}           % Style BST file.
\bibliography{bibliography}        % Bibliography file (usually '*.bib')

\end{document}

bibliography.bib

@ARTICLE{hankeknees,
    author  = {H. Hanke and D. Knees}, 
    title   = {A phase-field damage model based on evolving microstructure}, 
    journal = {Asymptotic Analysis}, 
    year    = {2017},
    volume  = {101}, 
    pages   = {149-180}
}   
@ARTICLE{lefever,
    author  = {E. Lefever}, 
    title   = {A hybrid approach to domain-independent taxonomy learning},
    journal = {Applied Ontology}, 
    year    = {2016},
    volume  = {11}, 
    number  = {3}, 
    pages   = {255-278}
}

As a try to debug the issue, I tried to change the name of the journal in the option of the documentclass, it worked but I got an error related to references (Bibliography not compatible with author-year citations. ...mand\NAT@force@numbers{}\NAT@force@numbers"). Any suggestions ?

0

The template runs only on TexLive instead of MikTex. I tried it on MacBook pro and it compiled normally.

0

I had to change iosart2x.cls. I added at the beginning of the file :

\RequirePackage{hyperref}

Everythings work fine after.

It seems that on my TexLive config (Macos), hyperref is not properly loaded (but i don't know why)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.