2

The text when I use Computer Modern doesn't look good, but the equations are fine

enter image description here

I don't know the problem. Can anybody help me?

I have this when I use overleafenter image description here

18
  • 1
    you are using miktex but haven't installed the cm-super package perhaps? (if you mean that the text is jagged/pixelated, it is hard to tell from your image) Jan 21, 2021 at 22:48
  • 2
    texstudio and texmaker are just editors used to write the file. neither makes a pdf which is the underlying tex system, but you may have two installed one with and one without cm-super. You still haven't shown the font list in the pdf so can not say for sure. Jan 21, 2021 at 23:17
  • 3
    \usepackage{lmodern} should also fix this.
    – Davislor
    Jan 21, 2021 at 23:39
  • 1
    @Davislor Cam you please make your suggestion to answer? Hope this may be one of an important point for some one...
    – MadyYuvi
    Jan 22, 2021 at 3:52
  • 2
    @Davislor sure but it doesn't actually answer the question. The user has a sub-optimal local computer modern configuration and (for example) that will affect many tex documents that they get from elsewhere, that should be easily fixed by installing cm-super. Just saying don't use computer modern is avoidance rather than fix (even if it works well) Jan 22, 2021 at 9:39

1 Answer 1

6

The issue (as others have mentioned) is that you don’t have the cm-super package installed in MikTeX. It’s falling back to old-style METAFONT files, which compile to pixelated bitmaps.

There are several other versions of Computer Modern that you can load instead. In PDFTeX, you can load the Type 1 version of Latin Modern with \usepackage{lmodern}. In LuaLaTeX or XeLaTeX, you can load the OpenType version of Latin Modern with \usepackage{unicode-math}, or New Computer Modern with \usepackage{newcomputermodern}

If that.s more options than you were looking for, my advice would be to load New Computer Modern in LuaLaTeX. It has the widest repertoire of glyphs, and gives you the option to select a slightly-thicker weight. But (as David Carlisle wisely mentioned in his comment) please do still install cm-super so that any documents you download compile correctly.

1
  • 2
    +1 (despite the bus comment under the question:-) Jan 22, 2021 at 17:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.