0

This has been asked a few times before, but according to the biblatex-chicago manual on page 178, this was supposed to be fixed in 1.0rc5 in Jan 2018 (at least for subtitles of books).

My problem is that I still get a comma after a question mark in both an incollection and article type.

I saw this solution which might work, but I am hoping that perhaps there is something that is wrong with how I am loading biblatex-chicago that I can easily fix.

Here is my MWE:

\documentclass[letterpaper,12pt]{report}
\usepackage{polyglossia}
\setmainlanguage[variant=us]{english}
\usepackage[english=american]{csquotes} 

\usepackage[noibid,backend=biber,notes,isbn=false,shorthandfull,shorthandfirst,inheritshorthand=true,citereset=chapter,longcrossref=bib]{biblatex-chicago}

\usepackage{filecontents}
    \begin{filecontents}{temp.bib}
    @collection{bigbook,
        editor = {John Q. Editormann},
        title  = {A Collection of Essays},
        publisher = {Oxford University Press},
        address = {Oxford},
        year = {1995}}
    @incollection{incol,
        crossref = {bigbook},
        author   = {Steve Authormann},
        title    = {Where is the Comma?},
        pages    = {1-15}}
    @article{art1,
        author   = {Mark Articlemann},
        title    = {Is there a Comma?},
        journal  = {Journal of Grammar Questions},
        volume   = {2},
        issue    = {3},
        year     = {1995},
        pages    = {16-30}}
    \end{filecontents}

\addbibresource{temp.bib}

\begin{document}
I need to reference this in a footnote.\footcite[12]{incol} But this is
another footnote.\footcite[18]{art1}
\clearpage
\printbibliography
\end{document}

And here is what the footnotes look like:

Footnotes

The commas should not be there after the question mark in the titles. What is the best way to remove them?

I went ahead and showed all the options I am currently using for biblatex-chicago even though they aren't necessary for this MWE.

Thanks in advance!

1 Answer 1

1

With \DeclarePunctuationPairs{<identifier>}{<characters>} you can tell biblatex after which <characters> the punctuation <identifier> is allowed. After all other punctuation <identifier> is suppressed. (Of course this only works properly if all punctuation marks are typeset with biblatex's punctuation commands. But that is the case in biblatex-chicago and other well-written biblatex styles.)

The default biblatex settings for the comma are

\DeclarePunctuationPairs{comma}{*!?}

which allows the comma after a an abbreviation dot, and after exclamation and question marks.

The american localisation modules issues \uspunctuation, which sets

\DeclarePunctuationPairs{comma}{*}

allowing a comma only after abbreviation dots and suppressing it in all other contexts.

But then biblatex-chicago explicitly overrides this decision (e.g. in chicago-notes.cbx, 2020/04/20 v 3.14)

% American-specific punctuation change for 16th edition %

\DefineBibliographyExtras{american}{%
  \DeclarePunctuationPairs{comma}{*!?}}

and allows commas after "!" and "?" again.

You can override this as follows

\documentclass[letterpaper,12pt]{article}
\usepackage{polyglossia}
\setmainlanguage[variant=us]{english}
\usepackage[english=american]{csquotes} 

\usepackage[backend=biber,notes,
  noibid,
%  citereset=chapter,
  shorthandfull,shorthandfirst,inheritshorthand=true,
  longcrossref=bib,
  isbn=false,
]{biblatex-chicago}

\DefineBibliographyExtras{american}{\DeclarePunctuationPairs{comma}{*}}

\begin{filecontents}{\jobname.bib}
@collection{bigbook,
  editor    = {John Q. Editormann},
  title     = {A Collection of Essays},
  publisher = {Oxford University Press},
  address   = {Oxford},
  year      = {1995},
}
@incollection{incol,
  crossref = {bigbook},
  author   = {Steve Authormann},
  title    = {Where is the Comma?},
  pages    = {1-15},
}
@article{art1,
  author   = {Mark Articlemann},
  title    = {Is there a Comma?},
  journal  = {Journal of Grammar Questions},
  volume   = {2},
  issue    = {3},
  year     = {1995},
  pages    = {16-30},
}
\end{filecontents}

\addbibresource{\jobname.bib}

\begin{document}
I need to reference this in a footnote.\footcite[12]{incol} But this is
another footnote.\footcite[18]{art1}

\printbibliography
\end{document}

Steve Authormann, “Where is the Comma?” In A Collection of Essays, ed. John Q. Editormann (Oxford: Oxford University Press, 1995), 12.//Mark Articlemann, “Is there a Comma?” Journal of Grammar Questions 2 (3 1995): 18.

1
  • Moewe to the rescue, again! Thanks so much, I hadn't looked to see that it was overridden. This works perfectly.
    – Paul
    Commented Jan 24, 2021 at 13:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .