When I open my Thesis.tex file I get "File not found"

enter image description here

Worst error description ever!?

This first occured when I opened the .tex file yesterday from my USB. My USB was suddenly write protected (don't know how to fix this either). So I copy the files to a new USB drive (as the files could still be read) but now I have got it again! (This time the USB is not write protected though)

It opens the file just fine and I can still work in it but building the pdf doesn't work (it doesn't finish).

That's the best description I can give.

I think I'm just going to start over copying and pasting the text but maybe you guys have a better suggestion?

  • Could you have opened a project file that includes thesis.tex and some other files that do not exist anymore? I don't know TeXmaker, so I don't know whether it handles projects this way (like TeXnicCenter does). – Werner May 31 '12 at 18:48
  • Did you rename the file or moved it to another location? If you can still open the file with a text editor, my only suggestion is to copy your code and recompile using another name. – azetina May 31 '12 at 19:14
  • Which TeXmaker version do you have? – Paulo Cereda Jun 1 '12 at 14:39
  • The same thing happened to me just now!!!! I am using Texmaker 3.3.3. Your description really translate what happens! But, as there is no answer yet and I do not have too much time, my solution was to copy and paste the code in other file .tex. – Davi Moreira Jun 23 '12 at 22:31
  • Working with TeX Live/Texaker on Ubuntu 13.04. The error message I get when compiling a file for the first time: "Log file not found". => It does compile though when I execute Texmaker with sudo rights, so I do believe it has something to do with directory permissions. But I still can't manage to get things right so that I can launch Texmaker normally. – user30340 May 7 '13 at 22:56

The problem is addressed in the following url.

Go to tools -> click on pdflatex. Thats it.

TexMaker - "File not found" when viewing as pdf

  • In this question, the problem is the missing write permission, while in the question you linked the problem was that the PDF had not yet been created. – Tom Bombadil Sep 21 '12 at 9:10
  • Cool worked like charm! :) – uday Jul 2 '13 at 1:58
  • 1
    That shows me a popup saying "Log File not found !" – Tvde1 Nov 5 '18 at 12:36

I had the same error given to me by TeXmaker and I found my way here, so just to add the "trivial" case, which caused problems on my end:

If you test-compile an empty document with no content in between the document tags, you will get the above error. The following will not work,

(~~ preamble ~~)



(~~ preamble ~~)

works perfectly fine. It's obvious that this is easy to rule out as a possible error source ;)

  • This was the problem for me. – mazunki May 28 '19 at 17:44
  • Me too, thanks! – James Ko Feb 9 '20 at 0:22

@Pizzaguru I mostly work on TeXmaker. After some time I figured out how you ended up into this "File not found problem". In future, please provide the steps that bring into the errors. Then it's easy to understand and find solutions.

When you run LaTeX (pdflatex) you need write permission to write the PDF. So your LaTeX compiler is not able to generate a pdf from .tex source. The .pdf file was not found in you case, hence the error from TeXmaker.

Try working on a local drive where you have full write permissions for the drive.

Not the answer you're looking for? Browse other questions tagged or ask your own question.