22

EDITED:11-23-2010 In case anyone stumbles upon this question and has a similar problem. The Ubuntu/Debian repositories have an old version of revtex that exhibit this bug. Until the repos are updated, there is a .deb file available in the bug report that installs the new version of revtex

--

I'm Trying to get multiple affiliations for the author list when using revtex-4.1

The default behavior is to group the authors together according to affiliation as so:

alt text

However, this requires you to group authors together in an unnatural way, and usually in a way that conflicts with authorship politics. Even if you switch to superscriptaddress mode, the requirement on grouping still remains.

For example, If I want to have two authors share an affiliation, but have one of the authors have a second affiliation, the whole thing ends up ignoring the first affiliation of the second author: e.g.

\author{J. T. Ripper}
\affiliation{Bethlem Royal Psychiatric Hospital}
\author{Bugs Bunny}
\affiliation{Looney Tunes}
\author{Daffy Duck}
\affiliation{Looney Tunes}
\affiliation{Warner Brothers}

Gives you the following

alt text

If you try to remove bug's affiliation then they both end up inheriting both affiliations. Like so:

\author{J. T. Ripper}
\affiliation{Bethlem Royal Psychiatric Hospital}
\author{Bugs Bunny}
\author{Daffy Duck}
\affiliation{Looney Tunes}
\affiliation{Warner Brothers}

alt text

What I want it to do is to give Daffy two superscripts, and Bugs bunny only one. The picture gets even harrier if (for example) I try to put J Ripper in between bugs and daffy. Then the numbers get even more screwed up. Using alt affiliations doesn't solve the problem because the alt affilliation goes into a footnote.

There used to be a "feature" in revtex-4, that if you used \address instead of \affiliation , then the whole thing behaves as expected. However, it seems that the latest version of revtex4-1, has patched this "bug", and now even old documents that worked fine, have broken affiliations. e.g.:

With Revtex 4:

alt text

With Revtex 4-1:

alt text

Ignore the style differences (the first one was typeset by arxiv with a prl instead of an api style).The latex behind the two is identical. Full Disclosure: I'm one of the twenty co-authors

2 Answers 2

14

Works for me. I am using

Document Class: revtex4-1 2010/07/25/20:33:00 4.1r 

which fixes a number of bugs in the affiliation code.

Testcase:

\documentclass[superscriptaddress]{revtex4-1}
\begin{document}
\author{J. T. Ripper}
\affiliation{Bethlem Royal Psychiatric Hospital}
\author{Bugs Bunny}
\affiliation{Looney Tunes}
\author{Daffy Duck}
\affiliation{Looney Tunes}
\affiliation{Warner Brothers}
\maketitle
\end{document}

Result: alt text

1
  • Well This makes me feel stupid. Both Debian and Ubuntu had an old version in their repos. And I thought it wasn't the package because the systems are maintained by different people sigh. Anyway, thanks a bunch, I had to hack in the new revtex and I'm off to go bug canonical.
    – crasic
    Commented Nov 23, 2010 at 9:34
5

This can be accomplished by selecting the class option superscriptaddress in documentclass.

\documentclass[
reprint,
superscriptaddress,
 amsmath,amssymb,
 aps,
pra,
]{revtex4-2}

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .