I started using XeTeX with polyglossia for typesetting Bengali. I use the following command for turning on language-specific ligatures:


Everything seems to work fine, except that if a consonant is followed by U+09CD (Virama) followed by U+09AF (Bengali letter Ya), I do not get the expected glyph in the output. The ligature is not formed for some reason. All other combinations seem to work. I have tried with multiple fonts, so I do not think it is a font issue.

Here is a picture of the problem

enter image description here

Thanks a lot for your patience!

Setup: MikTeX 2.9.4476 on 32-bit Windows 7


I have tried it out with the following code and as you can see, the ligature is only formed correctly in Code2000. Strangely enough, I get this error for all fonts except for Code2000:

* fontspec warning: "script-not-exist"
* Font 'ArialUnicodeMS' does not contain script 'Bengali'.

But when I look it up in Font Book.app, it tells me that at least BanglaMNand BanglaSangamMN do have the Bengali script (apart from Code2000).

In TextEdit.app, both BanglaMN and BanglaSangamMN have the correct ligated form for kya, which is even stranger. (Arial Unicode MS does not, though.)

From my point of view, this seems like a mixture of both a font and XeLaTeX (or fontspec) issue.


%!TEX TS-program = xelatex
%!TEX encoding = UTF-8 Unicode





\noindent {\bengalifontA ক্য }\vfill
{\bengalifontB ক্য }\vfill
{\bengalifontC ক্য }\vfill
{\bengalifontD ক্য }\vfill


Bengali Ligatures

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.