2

I receive an error in MikTex, using revtex. The error occurs when bibtex activates.

Any ideas on a solution? Output is below:

This is BibTeX, Version 0.99d (MiKTeX 2.9.6930 64-bit)

The top-level auxiliary file: humanomicsPropertiesPreprint.aux

The style file: apsrev4-2.bst

Database file #1: humanomicsPropertiesPreprintNotes.bib

Database file #2: bib.bib

control{REVTEX42Control}, control.key{N/A}, control.author{N/A}, control.editor{N/A}, control.title{N/A}, control.pages{N/A}, control.year{N/A}, control.eprint{N/A}, 
control{apsrev42Control}, control.key{N/A}, control.author{08}, control.editor{1}, control.title{0}, control.pages{0}, control.year{1}, control.eprint{N/A}, 

Warning--jnrlst (dependency: not reversed) set 1

apsrev4-2.bst 2019-01-14 (MD) hand-edited version of apsrev4-1.bst

Control: key (0) 

Control: author (8) initials jnrlst

Control: editor formatted (1) identically to author

Control: production of article title (0) allowed

Control: page (0) single

Control: year (1) truncated

Control: production of eprint (0) enabled

Warning--empty year in SIC
"J. High Energy Phys." is a string literal, `journal' is a missing field
---they aren't the same literal types for entry Cou
while executing---line 3516 of file apsrev4-2.bst

2 Answers 2

2

The error is caused by file apsrev4-2.bst in the ReVTeX4-2 distribution. To fix it replace in the preamble

\bibliographystyle{apsrev4-2} by \bibliographystyle{apsrev4-1}

Naturally, the package RevTeX4-1 should be installed. Otherwise, you have to install the file apsrev4-1.bst manually.

0

You can still use revtex4-2 by manually adding , journal = "" to each @article without a journal field (i.e., those have only an arxiv number).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.