2

I am writing a document using this template which is using this bib style file. Having the same author for multiple references is leading to dashes as shown below.

I tried looking for name.or.dash or the source code which is responsible for this behavior but I could not. Kindly help! enter image description here

Update: I just found out that .sty file I linked above is not used as it is part of an if/else block. biblatex-chicago.sty which is not even there in the project source, is being used. when I try to use biblatex-apa it gives me an error that biblatex-apa.sty is not found, wondering how is it able to locate biblatex-chicago.sty on its own.

1 Answer 1

3

When the usebiblatex flag in the template is set, its bibliography setup very roughly comes down to

\documentclass[american]{article}
\usepackage[T1]{fontenc}
\usepackage{babel}
\usepackage{csquotes}
\usepackage[
  backend=biber,
  authordate,
  doi=only,
  isbn=false
]{biblatex-chicago}

\addbibresource{biblatex-examples.bib}

\begin{document}
Lorem \autocite{sigfridsson,knuth:ct:a,knuth:ct:b,knuth:ct:c}

\printbibliography
\end{document}

which indeed produces dashes instead of repeated author names

Dashes for repeated Knuth

You can use the option dashed=false, to turn this behaviour off and give you repeated names in the bibliography.

\documentclass[american]{article}
\usepackage[T1]{fontenc}
\usepackage{babel}
\usepackage{csquotes}
\usepackage[
  backend=biber,
  authordate,
  dashed=false,
  doi=only,
  isbn=false
]{biblatex-chicago}

\addbibresource{biblatex-examples.bib}

\begin{document}
Lorem \autocite{sigfridsson,knuth:ct:a,knuth:ct:b,knuth:ct:c}

\printbibliography
\end{document}

Repeated Knuth

If you want to switch the biblatex style completely, you need to switch from \usepackage{biblatex-chicago} to \usepackage{biblatex}. AFAIK biblatex-chicago styles are the only styles that are loaded via a wrapper package, all other biblatex styles are loaded via biblatex, e.g. biblatex-apa is used as

\documentclass[american]{article}
\usepackage[T1]{fontenc}
\usepackage{babel}
\usepackage{csquotes}
\usepackage[
  backend=biber,
  style=apa,
]{biblatex}

\addbibresource{biblatex-examples.bib}

\begin{document}
Lorem \autocite{sigfridsson,knuth:ct:a,knuth:ct:b,knuth:ct:c}

\printbibliography
\end{document}

APA bibliography

9
  • wow. you solved all my problems. much thanks. love you <3 Feb 5, 2021 at 6:03
  • is it possible to use apa for header style as well, instead of chicago? 13251061749486220117.googlegroups.com/attach/42881f24dc34c/… Feb 5, 2021 at 6:05
  • 2
    @vipin8169 Sorry, no idea. I only know about bibliographies. You may want to try asking a new question. In that case I strongly encourage you to include a proper minimal, compilable example document in your question instead of a link to a 1000-odd line template. (You may also want to explain what you mean by APA header style.) If you want to write an APA-conforming document maybe you should look into the apa7 document class and drop the template altogether.
    – moewe
    Feb 5, 2021 at 6:07
  • Could you see how to possibly indent the para. they are appearing with zero indentation. I tried looking for the piece of code that is causing indent to be 0em but could not find it. also tried setting \setlength{\parindent}{4em} did not work either. parindent does not exist in the current document, and setting it does not work. Feb 5, 2021 at 7:53
  • 1
    @vipin8169 That said, if you are lucky you might get an answer without posting a proper MWE if you just link to the full template. People might know what to look for and may be able to tell you what is going on without running the full document (similar to what I did in this question: I found the biblatex-related code and showed what was going on, but at least I wouldn't know where to start).
    – moewe
    Feb 5, 2021 at 8:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.