I have succeeded in having a multiscript document using polyglossia. I tried to use biber to have a multiscript bibliography. Every thing compiles well but the Arabic Script in the .bib file doesn't print in the pdf file. It appears correctly in the TexWorks log but doesn't appear at all int he pdf file, with no related warning in the log, and even after forcing utf-8 encoding.

Here is the Minimal code:

in main.tex:



\newfontfamily\arabicfont[Script=Arabic,Scale=3]{Arabic Typesetting}


in newref.bib

author ={عزيزة مبارك العلوني, مريم عبد الرحمن السهلي, مهرة فارس المطيري, ندى محمد ميمني},
journal = {رسالة ماجستير غير منشورة},
title = {برنامج تعليمي الكتروني في تنمية بعض من مهارات الاستعداد للقراءة لدى  أطفال ما قبل المدرسة},
url = {http://www.minshawi.com/node/2241},
year = 2011

Update: here is the log:

Package biblatex Warning: Biber reported the following issues
(biblatex)                with 'arabic1':
(biblatex)                - Name "ط¹ط²ظٹط²ط© ظ…ط¨ط§ط±ظƒ ط§ظ„ط¹ظ„ظˆظ†ظٹ, ظ…ط±ظٹظ
… ط¹ط¨ط¯ ط§ظ„ط±ط­ظ…ظ† ط§ظ„ط³ظ‡ظ„ظٹ, ظ…ظ‡ط±ط© ظپط§ط±ط³ ط§ظ„ظ…ط·ظٹط±ظٹ, ظ†ط¯ظ‰ ظ…
ط­ظ…ط¯ ظ…ظٹظ…ظ†ظٹ" has too many commas: skipping name.

Package biblatex Info: Reference section=0 on input line 74.
Package biblatex Info: Reference segment=0 on input line 74.
Requested font "[lmsans12-regular]:mapping=tex-text" at 12.0pt
 -> C:/Program Files/MiKTeX 2.9/fonts/opentype/public/lm/lmsans12-regular.otf
Requested font "[lmsans10-regular]:mapping=tex-text" at 10.95pt
 -> C:/Program Files/MiKTeX 2.9/fonts/opentype/public/lm/lmsans10-regular.otf
Requested font "[lmsans10-bold]:mapping=tex-text" at 12.0pt
 -> C:/Program Files/MiKTeX 2.9/fonts/opentype/public/lm/lmsans10-bold.otf
File: TitlePage/GUC-logo-ss.ps Graphic file (type eps)
Requested font "[lmsans17-regular]:mapping=tex-text" at 17.28pt
 -> C:/Program Files/MiKTeX 2.9/fonts/opentype/public/lm/lmsans17-regular.otf
File: TitlePage/logo2.eps Graphic file (type eps)
Requested font "[lmsans10-bold]:mapping=tex-text" at 17.28pt
 -> C:/Program Files/MiKTeX 2.9/fonts/opentype/public/lm/lmsans10-bold.otf

Overfull \vbox (91.82722pt too high) detected at line 83

Requested font "[lmsans10-bold]:mapping=tex-text" at 10.95pt
 -> C:/Program Files/MiKTeX 2.9/fonts/opentype/public/lm/lmsans10-bold.otf
Requested font "[lmroman10-regular]:mapping=tex-text" at 10.95pt
 -> C:/Program Files/MiKTeX 2.9/fonts/opentype/public/lm/lmroman10-regular.otf

] [1

] ("E:\Lolla\My Work\Masters\Thesis files\Thesis\main.toc"
Requested font "[lmroman12-bold]:mapping=tex-text" at 12.0pt
 -> C:/Program Files/MiKTeX 2.9/fonts/opentype/public/lm/lmroman12-bold.otf
Requested font "[lmroman8-regular]:mapping=tex-text" at 8.0pt
 -> C:/Program Files/MiKTeX 2.9/fonts/opentype/public/lm/lmroman8-regular.otf
Requested font "[lmroman6-regular]:mapping=tex-text" at 6.0pt
 -> C:/Program Files/MiKTeX 2.9/fonts/opentype/public/lm/lmroman6-regular.otf
Requested font "cmmi12" at 12.0pt
 -> cmmi12
Requested font "cmmi8" at 8.0pt
 -> cmmi8
Requested font "cmmi6" at 6.0pt
 -> cmmi6
Requested font "cmsy10" at 12.0pt
 -> cmsy10
Requested font "cmsy8" at 8.0pt
 -> cmsy8
Requested font "cmsy6" at 6.0pt
 -> cmsy6
LaTeX Font Info:    External font `cmex10' loaded for size
(Font)              <12> on input line 7.
LaTeX Font Info:    External font `cmex10' loaded for size
(Font)              <8> on input line 7.
LaTeX Font Info:    External font `cmex10' loaded for size
(Font)              <6> on input line 7.
Requested font "cmr8" at 8.0pt
 -> cmr8
Requested font "cmr6" at 6.0pt
 -> cmr6

Two things I noticed in the log, Joseph: first the Arabic Characters don't show here either, although they showed in the TexWorks log correctly. Also, there is the msans font requested. I have no idea why it is requested. As a workaround, I will try to set the English font to the same font for Arabic and see what happens...

  • It might be useful to see the logs here: you should have a LaTeX .log and ` Biber .blg one. (I assume you ran XeLaTeX, Biber and XeLaTeX again.) – Joseph Wright Jun 2 '12 at 8:02
  • Does everything appear in the .bbl file? I have seen this before where it's just a problem with fonts - it's all fine but the PDF viewer just doesn't have the fonts to display the text. – PLK Jun 2 '12 at 8:08
  • PLK..The font I am using prints the Arabic Script in the document correctly into the pdf file. I think I have to use something in the bib file that says that I will use Arabic now... like in the document I use the polyglossia commands \textArabic{} and \begin{Arabic} to show the Arabic Script. But I have no idea how to do this in a multiscript bibliography – Laila Jun 2 '12 at 11:27
  • Joseph, yes I ran XeLateX, Biber and XeLateX again. – Laila Jun 2 '12 at 11:28
  • I will post the logs – Laila Jun 2 '12 at 11:28

Not sure about Arabic and biber but you may want to have a look at persian-bib package.

  • Mr. Vafa, I installed the package.. is there an English documentation for it? – Laila Jun 2 '12 at 11:37
  • No, but there is an example that you can try. If you need further help, you can contact Mahmood Amintoosi (the maintainer of that package). I am sure that if you ask him, he will write an English documentation for his package too. – Vafa Khalighi Jun 2 '12 at 12:46
  • I can't seem to find the example – Laila Jun 2 '12 at 13:15
  • biblatex-example.tex: mirrors.ctan.org/biblio/bibtex/contrib/persian-bib/… – Vafa Khalighi Jun 2 '12 at 13:21
  • I have understood from the example that I have to use the package xpersian, but will I have to change the bib file? – Laila Jun 2 '12 at 15:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.