I am customizing this overleaf template for my thesis but I want it two sided. However, if I change oneside to twoside in the book class there is a mysterious first page appearing before the front page, with the number 2 at the bottom. Putting


before including the front page doesn't work. The solution given by @Werner here, that is, to include

usepackage{atbegshi}% http://ctan.org/pkg/atbegshi

in the preamble, also doesn't work. Increasing the margin inside geometry package settings doesn't work. What can I do? Any help is much appreciated.

As requested by David, I manage to get the very minimal version of the template and the problem comes from the use of \justify from the ragged2e package.

      ...TITLE PAGE...
  • Apologize @DavidCarlisle, I added a small code with the problem. Thanks for the help.
    – Filburt
    Feb 9 at 22:11
  • 1
    actually I was a bit harsh to say no information given you had the link, but still pointing to the external template isn't the most helpful form:-) Feb 9 at 22:13

\justify is like \center and should never be used in the command form, they are the internal implementations of \begin{justify} and \begin{center}.

The declaration form is \justifying (but should almost never be needed as justification is the default. However \justifying does not cause the extra page.


Using \documentclass[11pt,twoside,openright]{book}

(1) Comment %\AtBeginDocument{\AtBeginShipoutNext{\AtBeginShipoutDiscard}}

(2) Do not use \justify

\pagestyle{empty} %disable headers and footers
\pagenumbering{roman} %use roman page numbering in the frontmatter

  • Thanks for having looked into the template! :-)
    – Filburt
    Feb 9 at 22:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.