0

I am trying to index Arabic documents. The idx file generated is:

\indexentry{الوعي|hyperpage}{\RLE {١}}
\indexentry{المسؤولية|hyperpage}{\RLE {٢}}

When I run makeindex, I get this error in ilg file

This is makeindex, version 2.15 [TeX Live 2019] (kpathsea + Thai support).
Scanning input file Coaching.idx...
!! Input index error (file = Coaching.idx, line = 1):
    -- Illegal space within numerals in second argument.
!! Input index error (file = Coaching.idx, line = 2):
    -- Illegal space within numerals in second argument.
done (0 entries accepted, 2 rejected).
Nothing written in Coaching.ind.
Transcript written in Coaching.ilg.

How can I fix this? Is there a work-around to have an index generated? Thx

4
  • You should use xindy rather than makeindex for this task. – egreg Feb 15 at 10:48
  • I tried it but I guess I didn't do it right. Let me revisit and revert back. – OOzy Pal Feb 16 at 7:52
  • I tried once more. I am afraid xindy does not support Arabic. How can I create one? – OOzy Pal Feb 16 at 9:42
  • The problem is in {\RLE {١}}. Note the number is Arabic. If I remove {\RLE {١}} with {1}, things works fine. How to prevent makeidx from adding \RLE? – OOzy Pal Feb 16 at 12:07
0

I have found the solution. I have added the following:

\setdefaultlanguage[numerals=maghrib]{arabic}

and the idx outupt file is now:

\indexentry{الوعي|hyperpage}{1}
\indexentry{المسؤولية|hyperpage}{2}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.