I am trying to make the appendices to my Master's thesis. The template consists of several parts that are arranged in a file called "final.tex". I'm having two problems with appendices:

  1. I can keep the index the way I want it, but appendices A, B and C instead of starting with A.1, B.1 and C.1 start with A.1, A.1 and A.1 always, regardless of the letter of the appendices. I want the title of the appendices: "Anexos A", "Anexos B" and "Anexos C" not to have a letter in front, but that the subtitles have a letter, the dot and the number.
  2. The blank pages added in the appendices are not being assumed. When the number of pages is odd, the template is not putting a blank page in the appendices, as it does with the rest of the document.

How can I resolve these two issues? I've tried to see other Stack Exchange questions and tried to see if it worked, but I still haven't been able to get the template to work properly.

Code of the "final.tex" file:

%oneside ou openany serve para tirar paginas em branco depois das secções
% Omitting Page Numbers

% Packages
\captionsetup[table]{font={stretch=1,footnotesize}, labelfont=bf}
\captionsetup[figure]{font={stretch=1,footnotesize}, labelfont=bf}
\usepackage{afterpage}  % blank pages
\usepackage{multirow}  % table
%\usepackage[table, dvipsnames]{xcolor}  % table
\usepackage{xpatch}  % table
\usepackage{tabu}  % table
\usepackage{hhline}  % cell color does not overlap cell line
\usepackage{fancyhdr}  % headers
\usepackage{breakcites}  % references do not go though margins
\usepackage{sectsty}  % change chapter title size
\setcounter{tocdepth}{3}  % four level contents
\setcounter{secnumdepth}{3}  % numbered four level contents
\usepackage{amsfonts}  % math
\usepackage{amsmath}  % math
\usepackage{hyperref}  % references
  \let\@makechapterhead\@gobble % make \@makechapterhead do nothing
  []% init options
  {definição}% name
  {Definição}% title
  }% options
  {def}% prefix
%\newcommand{\rectangle}{{  % rectangle
%  \ooalign{$\sqsubset\mkern3mu$\cr$\mkern3mu\sqsupset$\cr}

%\newcommand\BibTeX{B{\sc ib}\TeX}

% References

% Blank Page

% Hide Blank Pages Numbers + Headers

% Space between numbers and text


\newgeometry{left=3cm, right=3cm, top=1cm, bottom=1.2cm}


\afterpage{\blankpage} %comentar para tirar paginas em branco


% Preamble for Thesis
\setmainfont{Times New Roman}
\let\cleardoublepage\clearemptydoublepage  % hide blank pages numbers + headers

%tenho um problema com a numeração das paginas






\afterpage{\blankpage} %comentar para tirar paginas em branco

% After Introductory Pages

\chaptertitlefont{\Huge} % to fit chapter title to one line







\pagestyle{plain}  % no more header 




Appendix A part code:

\section*{\Huge Anexos A}
\addcontentsline{toc}{chapter}{Anexos A}
%\chapter*{Anexos A}
%\addcontentsline{toc}{chapter}{Anexos A}
\section{Diferença de caminho óptico}

Appendix B part code:

\section*{\Huge Anexos B}
\addcontentsline{toc}{chapter}{Anexos B}
%\chapter*{Anexos A}
%\addcontentsline{toc}{chapter}{Anexos A}
\section{Distribuição log-normal}

Table of contents: enter image description here

Errors with parts "Anexos A" and "Anexos B":

enter image description here enter image description here enter image description here

1 Answer 1


You are resetting the numbering by using \appendix multiple times. Try using it before the whole appenix part only, like this:





    \section{Section in Appendix A}


    \section{Section in Appendix B}

  • This is perfect. It worked! Thanks for the help! Feb 23, 2021 at 13:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.