0

I recently added the LatexTools package to Sublime Text 3 through the Package manager. I am running Ubuntu 20.04 and after ensuring the paths were properly set up, everything worked out of the box, including the Ctrl-l-j functionality to locate the region in the .pdf that corresponded to the position of the cursor in the .tex code.

A few days passed and I tried using LatexTools again. This time LatexTools could not detect my version of python. I use pyenv, so my python path is /home/username/.pyenv/shims/python. After setting the path in LatexTools settings, I can build the pdf fine with Ctrl-b, but the Ctrl-l-j functionality is gone. Importantly, I can see in the console that Ctrl-l is detected, and moreover that the cursor position is detected. Upon hitting Ctrl-l-j, I see

True True True
Jump to:  3 14
<class '_latextools_evince_viewer.EvinceViewer'>
Running "ps xv"

Any tips on how to recover the functionality (which is the only reason for me to have LatexTools)? Here's what I've done so far.

  • Reset to default settings
  • Removed the package completely and reinstalled it. No change.
  • I may have installed the BracketHighlighter package after installing LatexTools. I installed BracketHighlighter, restarted Sublime, and the problem persisted.

I am working with the following minimal working example.

\documentclass{article}
\begin{document}
Test
\end{document}

Here is the console output with personal paths redacted.

Welcome to thread Thread-11
Running "latexmk -cd -f -pdf -interaction=nonstopmode -synctex=1 test.tex"
Finished normally
0
False True True
Jump to:  6 0
<class '_latextools_evince_viewer.EvinceViewer'>
Running "ps xv"
Running "/home/username/.pyenv/shims/python /home/username/.config/sublime-text-3/Packages/LaTeXTools/evince/evince_forward_search ...test.pdf 7 ...test.tex"

Below is the output of LatexTools --> Check system.

Program      Location                                          Status     Version
-------      --------                                          ------     -------
sublime      /usr/bin/subl                                     available  Sublime Text Build 3211
latexmk      /usr/bin/latexmk                                  available  Latexmk, John Collins, 26 Dec. 2019. Version 4.67
pdflatex     /usr/bin/pdflatex                                 available  pdfTeX 3.14159265-2.6-1.40.20 (TeX Live 2019/Debian)
xelatex      /usr/local/texlive/2020/bin/x86_64-linux/xelatex  available  XeTeX 3.14159265-2.6-0.999992 (TeX Live 2020)
lualatex     /usr/bin/lualatex                                 available  This is LuaTeX, Version 1.10.0 (TeX Live 2019/Debian)
biber        /usr/local/texlive/2020/bin/x86_64-linux/biber    available  biber version: 2.16
bibtex       /usr/bin/bibtex                                   available  BibTeX 0.99d (TeX Live 2019/Debian)
bibtex8      /usr/bin/bibtex8                                  available  This is 8-bit Big BibTeX version 0.99d
kpsewhich    /usr/bin/kpsewhich                                available  kpathsea version 6.3.1
convert      /usr/bin/convert                                  available  ImageMagick 6.9.10-23 Q16 x86_64 20190101 https://imagemagick.org
ghostscript  /usr/bin/gs                                       available  GPL Ghostscript 9.50 (2019-10-15)

Packages for equation preview  Status
-----------------------------  ------
standalone                     missing
preview                        missing
xcolor                         available
amsmath                        available
amssymb                        available
latexsym                       available
mathtools                      available

Builder      Status
-------      ------
traditional  available

Builder Setting  Value
---------------  -----
display_log      False
linux            {}   
osx              {}   
windows          {}   

Viewer  Status     Location
------  ------     --------
evince  available  /usr/bin/evince

1 Answer 1

0

Hah! Months later I installed Sublime 4 and tried to reset my LatexTools settings to default. Lo and behold, Ctrl-click functionality returned! I shut down Sublime, did other stuff, and it failed again.

This time I observed the comment

    // Both Python2 and Python3 are supported, but must have the DBus bindings
    // installed.

DBus bindings allow for precisely this kind of interface. Simply changing "python": "" to "python": "/usr/bin/python3" restored most functionality.

In case this helps anyone out there, since LatexTools is the only package (no longer supported it seems) which allows for this crucial ctrl-click functionality.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .