2

I have a problem with the apa7 package in stu mode. I tried using the option noextraspace in \documentclass because the spacing between headings of the same layer and the trailing text bodies varied. When I used noextraspace this problem was solved but another one occurred: on the title page, title and author were printed in one line. This, of course, does not work. I have no idea how to fix this problem.

I would be very glad to receive Your suggestions :-)

\documentclass[stu, fontsize = 10pt, a4paper,noextraspace, floatsintext]{apa7} 
% noextraspace: stu mode, removes some of the vertical space between certain elements 
% (e.g., headers and text) to more closely resemble true double-spacing (at your own risk).

\usepackage[american]{babel}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{csquotes}

\linespread{1.5}

\usepackage[style=apa,sortcites=true,sorting=nyt,backend=biber]{biblatex}
%\DeclareLanguageMapping{american}{american-apa}
\addbibresource{trees.bib}

\title{Depression among Trees}

\author{Alpha Beta}
\affiliation{Department of Psychology}

\course{Cours XY}
\professor{Dr. Dr.}
\duedate{March 31, 2100}


\abstract{Blabla Blubbblubb}


\begin{document}
\maketitle
Blabla Blubbblubb

\end{document}

output of MWE showing the problem

5
  • Mhh, with apa7.cls v2.07 (2020/12/05 ), which isn't even the newest version, title and author are on separate lines in your MWE. Do you have a current version of apa7.cls? Can you share the .log file of your LaTeX run on the MWE with us (it might be too long for the question, so you can upload it to a text-sharing website such as pastebin.com or gist.github.com)? – moewe Mar 5 at 12:42
  • 1
    Completely, unrelated to your question, but for APA style I would replace \usepackage[style=apa,sortcites=true,sorting=nyt,backend=biber]{biblatex} with \usepackage[style=apa, backend=biber]{biblatex}: sortcites is already implied by style=apa, and sorting=nyt, actually disables APA sorting. The commented line%\DeclareLanguageMapping{american}{american-apa} can be removed with versions of biblatex-apa released after November 2018. – moewe Mar 5 at 12:44
  • Thank you, moewe, for your comment. The second one I applied directly. It works but didn't influence the output until now. For the first one, I need to do some research on which is my current version of apa7.cls (and where I can even find it or change it). – hanna Mar 5 at 20:37
  • Add \listfiles to the top of your .tex file (even before \documentclass). Then compile your document. You will find all package versions neatly listed in the .log file. But if you just upload the whole .log file as suggested in my first post, we can have a look at the package versions as well. – moewe Mar 6 at 6:13
  • Dear moewe, you were right with the idea that an older version of apa7.cls caused the issue. It was a small operation on my software distribution to include a new file but now it works:-)) Thank you! – hanna Mar 7 at 7:15
0

This bug was corrected in apa7 version 2.05. The latest version is 2.10 and can be found on CTAN.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.