1

I just finished installing and updating TeX Live 2020 on Windows 10. I performed a full installation of TeX Live. Now, compiling this simple document:

% !TEX program = lualatex
\documentclass[a4paper, 10pt, extrafontsizes]{memoir}

\begin{document}
Text
\end{document}

I receive this error message:

This is LuaHBTeX, Version 1.12.0 (TeX Live 2020/W32TeX) 
 restricted system commands enabled.
(c:/Users/marco/Downloads/temp/temp.tex
LaTeX2e <2020-02-02> patch level 5
 L3 programming layer <2020-03-06>
Calling deprecated Lua function strcmp (c:/texlive/2020/texmf-dist/tex/latex/memoir/memoir.cls
Document Class: memoir 2020/10/04 v3.7n configurable book, report, article document class
(c:/texlive/2020/texmf-dist/tex/generic/iftex/iftex.sty) (c:/texlive/2020/texmf-dist/tex/latex/lm/t1lmr.fd) (c:/texlive/2020/texmf-dist/tex/latex/memoir/mem10.clo) (c:/texlive/2020/texmf-dist/tex/latex/lm/lmodern.sty) (c:/texlive/2020/texmf-dist/tex/latex/base/fontenc.sty) (c:/texlive/2020/texmf-dist/tex/latex/tools/array.sty) (c:/texlive/2020/texmf-dist/tex/latex/tools/dcolumn.sty) (c:/texlive/2020/texmf-dist/tex/latex/tools/delarray.sty) (c:/texlive/2020/texmf-dist/tex/latex/tools/tabularx.sty) (c:/texlive/2020/texmf-dist/tex/latex/textcase/textcase.sty))

! LaTeX Error: File `l3backend-pdfmode.def' not found.

How can I solve this problem? Thank you very much for your help!

9
  • 1
    something it not up-to-date. check for updates and check if you have some local format hiding the system formats. Mar 6 at 21:30
  • @UlrikeFischer If I run tlmgr update -all, I receive this message: ‘tlmgr.pl: no updates available’. If I run tlmgr update --self, I receive this message: ‘tlmgr.pl: no self-updates for tlmgr available’. And tlmgr search l3backend returns ‘l3backend - LaTeX3 backend drivers’. How can I check about the formats?
    – Marco87
    Mar 7 at 0:51
  • @DavidCarlisle I had seen that answer before. However it doesn’t solve my problem. Could a fresh installation from scratch be the solution?
    – Marco87
    Mar 7 at 0:52
  • kpsewhich --all -engine=pdftex pdflatex.fmt probably reports two formats Mar 7 at 2:00
2

I experienced the same issue after a recent tlmgr update --all with texlive 2020. Reinstalling l3backends, l3kernel didn't help.

The changelog for l3backends reads:

[2020-09-01]

Changed

...

  • Split pdfmode driver into pdfTeX- and LuaTeX-specific files ...

so, evidently my recent update picked up this change (it's been a while since I updated).

Then I noticed that when running pdflatex I get:

LaTeX2e <2020-02-02> patch level 5 L3 programming layer <2020-04-06>

So an old L3 version (which preceds the change to l3backend change) is being used, even though L3 had supposedly just been updated to something more recent.

Just as an extra data point, I also noticed that xetex didn't seem to have similar issues.

Following the comment by @David_Carlisle, I ran kpsewhich --all -engine=pdftex pdflatex.fmt and found that I have two locations reported on my system:

/home/craig/.texlive2020/texmf-var/web2c/pdftex/pdflatex.fmt /home/craig/texlive/2020/texmf-var/web2c/pdftex/pdflatex.fmt

I renamed the first one, and the problem went away.

Some related issues suggested that you may need to run mktexlsr, though I didn't need to.

Good luck.

1
  • I see exactly the same issue. I just install a new fresh TexLive 2020, and update all the packages. Then, I see the same issue when compiler a minimal tex file. If I run the pdflatex, I got the l3backend-pdfmode.def not found issue, if I run pdfxelatex, I got the l3backend-xdvipdfmx.def not found issue. I have tried your method, and kpsewhich --all -engine=pdftex pdflatex.fmt only returns one location. So, not sure how to fix this issue. Thanks.
    – ollydbg23
    Mar 30 at 4:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.