6

I am trying to remove the spacing before the chapter. I have found several solutions using titlesec. Whenever I use such solutions I get errors of missing numbers and illegal units of measures for \section.

Since I am just working myself into using LaTeX I don't have a good understanding about the packages and how they affect each other.

This is what I have tried

\documentclass[a4paper,12pt]{scrreprt}

\usepackage[ngerman]{babel}
\usepackage[T1]{fontenc}
\usepackage{blindtext}

\usepackage{titlesec}

% this isn't working
\titlespacing*{\chapter}{0pt}{0pt}{40pt}

\begin{document}
    \blinddocument
\end{document}

So what is a good way to reduce the spacing before the chapters?

1
  • 1
    Off topic: Load hyperref after your other packages. \usepackage[utf8]{inputenc is not needed with an uptodate TeX distribution. Do not change \parskip and \parindent manually. You could use KOMA-Script option parskip=half or \parskip=half- or \parskip=full. – esdd Mar 8 at 10:57
6

titlesec is incompatible with KOMA-classes (like scrreprt you're using), but you can adjust the spacing with \RedeclareSectionCommand instead:

\RedeclareSectionCommand[beforeskip = 0pt,afterindent=false]{chapter}

For a more detailed explanation on how to change chapter/section formats, have a look at section 21.8. of the KOMA manual (en de).

2
  • Thank you, I'll read the documentation, works like a charm, Upvote will come soon :) – Thomas Christopher Davies Mar 8 at 10:48
  • 1
    Alternatively, you could stick with titlesec and not use scrreprt instead. – chsk Mar 8 at 10:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.