1

I am very new to LaTeX and this whole environment is pretty confusing to me so far, so please bear with me if I did sth stupid!

Hope that the MWE below is a good starting point:

\documentclass[fontsize=12pt,english]{report}
% package loading
% encoding
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc} % new

% page and text layout setup
\usepackage[a4paper,top=20mm,bottom=10mm,left=20mm,right=50mm]{geometry}

% language and spelling check
\usepackage{babel}

% miscellaneous document formatting
\usepackage{setspace}
\usepackage{titlesec}
\usepackage{fontspec}

% document structuring
% table of content formatting
\usepackage{tocloft}
% appendix
\usepackage{appendix}

% tables and lists
\usepackage{enumitem}
\usepackage{longtable}

% graphics and images display
\usepackage{graphicx}
\graphicspath{ {images/} }

% table and list formatting and referencing
\usepackage{caption}
\usepackage{subcaption} 

% math symbols and formula display
\usepackage{mathtools}
\usepackage{amsmath}
\usepackage{amssymb}
\usepackage{csquotes}

% including hyperlinks in the ToC for easier navigation
\usepackage{hyperref}
\hypersetup{pdfborder={0 0 0}}

% bibliography management and back-end
% setting referencing + citation styles
\usepackage[backend=biber, style=ext-authoryear, autocite=footnote, maxnames=1, sorting=nyt, sortcites=true, giveninits=true, uniquename=init]{biblatex}

\DeclareInnerCiteDelims{footcite}{\bibopenparen}{\bibcloseparen}

% customize bibliography formatting
\renewcommand{\multinamedelim}{\slash\space}
\renewbibmacro{in:}{ %eliminates the 'in' in the bibliography
\ifentrytype{article}{}{%
\printtext{\bibstring{in}\intitlepunct}}}

% reference your '.bib' file that stores all your sources
\addbibresource{references.bib}

% advanced document formatting
% line spacing, paragraph indention and paragraph spacing
\setlength{\parindent}{0pt}
\setlength{\parskip}{6pt}
\onehalfspacing % \renewcommand{\baselinestretch}{1.5} 
\pagestyle{plain}

% redefining title layouts
\titleformat{\chapter} {\normalfont\bfseries}{\thechapter.}{8pt}{} 
\titleformat{\section} {\normalfont\bfseries}{\thesection.}{8pt}{}
\titleformat{\subsection} {\normalfont\bfseries}{\thesubsection.}{8pt}{}
\titleformat{\subsubsection} {\normalfont\bfseries}{\thesubsubsection.}{8pt}{}
\titleformat{\subsubsubsection} {\normalfont\bfseries}{\thesubsubsubsection.}{8pt}{}

% title spacing for chapters and lower-level sections
\titlespacing*{\chapter}{0pt}{0pt}{0pt}
\titlespacing*{\section}{0pt}{0pt}{0pt}
\titlespacing*{\subsection}{0pt}{0pt}{0pt}
\titlespacing*{\subsubsection}{0pt}{0pt}{0pt}
\titlespacing*{\subsubsubsection}{0pt}{0pt}{0pt}

% set font
\setmainfont{Times New Roman}

% define any style difference to main document before begin document
\pagenumbering{roman}
\renewcommand*\contentsname{Table of Contents}

% main document creation
\begin{document}
   
\input{titlepage}

\addcontentsline{toc}{section}{Abstract}
\input{chapters/Abstract}

\tableofcontents

\newpage

\addcontentsline{toc}{section}{List of Figures}
\listoffigures
\newpage

\addcontentsline{toc}{section}{List of Tables}
\listoftables
\newpage

\addcontentsline{toc}{section}{Table of Attachments}
\chapter*{Table of attachments}
\input{chapters/Table_of_attachments}

\addcontentsline{toc}{section}{List of Abbreviations}
\chapter*{List of abbreviations}
\input{chapters/List_of_abbreviations}

\addcontentsline{toc}{section}{List of Symbols}
\chapter*{List of symbols}
\input{chapters/List_of_symbols}

% Introduction title
\chapter{Introduction}
\pagenumbering{arabic}
\input{chapters/Introduction}

% Chapter One Title
\chapter{Literature review}
\input{chapters/Chapter01}

% Chapter Two Title
\chapter{Empirical analysis}
\input{chapters/Chapter02}

% Chapter Three Title
\chapter{Discussion of results}
\input{chapters/Chapter03}

% Conclusion Title
\chapter{Conclusion}
\input{chapters/Conclusion}

\addcontentsline{toc}{section}{Appendix}
\appendix
\input{chapters/Appendix}

\addcontentsline{toc}{section}{References}
\printbibliography[title={References}]
\newpage

\addcontentsline{toc}{section}{Acknowledgements}
\chapter*{Acknowledgements}
\input{chapters/Acknowledgements}
\newpage

\addcontentsline{toc}{section}{Declaration of Academic Integrity}
\chapter*{Declaration of academic integrity}
\input{chapters/Statement_integrity}

\end{document}

Currently, I am seeing three errors.

  1. /usr/local/texlive/2017/texmf-dist/tex/latex/biblatex/biblatex.sty, line 13046 Package biblatex Error: Style 'ext-authoryear' not found. l.13046 \RequireBibliographyStyle{\blx@bbxfile}. The bibliography style 'ext-authoryear' could not be found.
  2. /usr/local/texlive/2017/texmf-dist/tex/latex/biblatex/biblatex, line 13047 Package biblatex Error: Style 'ext-authoryear' not found. See the biblatex package documentation for explanation l.13047 \RequireCitationStyle{\blx@cbxfile}. The citation style 'ext-authoryear.sty' could not be found.
  3. l.61 \DeclareInnerCiteDelims{footcite}{\bibopenparen}{\bibcloseparen} The control sequence at the end of the top line of your error message was never \def'ed.

Note that, whenever I change the style back to the base biblatex author year style, the citations and footnotes work just fine, expect the DeclareInnerCiteDelime command doesn't seem to do anything, and I am still missing the parentheses around the year in my footnotes.

Would highly appreciate any pointers and/or comments! Thanks

10
  • 1
    You are running TeX Live 2017 which does not provide the biblatex-ext files. The first public release of this package was 2018-03-08
    – Ivan
    Mar 11, 2021 at 13:48
  • Oh man, ... That caused me hours of headache trying to debug and rewriting the whole preamble numerous times in the attempt to catch the error that was causing all this. Thanks! Highly appreciated! I am using my school's online LaTeX editor shareLaTeX. Might need to work on my offline based Tex software program then. Mar 11, 2021 at 14:12
  • There was an option hidden deep inside the project settings. Two Tex Live versions available. Tex Live 2017.1 and Tex Live 2020.1. Changed the setting and worked like a charm! Once I knew where to look, it was easy! Your help was much appreciated Ivan! Mar 11, 2021 at 14:26
  • @Ivan Do you want to type up a quick answer here? Or do we close this as too localised?
    – moewe
    Mar 11, 2021 at 16:34
  • Unrelated to your question, but since you are using biblatex-ext you can remove your redefinition of \renewbibmacro{in:} and use the option articlein=false, instead. \renewcommand{\multinamedelim}{\slash\space} can be replaced with \DeclareDelimFormat{multinamedelim}{\addslash\space} and you may want to do something for finalnamedelim otherwise things might end up looking weird (maybe \DeclareDelimAlias{finalnamedelim}{multinamedelim})
    – moewe
    Mar 11, 2021 at 17:02

1 Answer 1

1

The trick here was already hidden in the helpful error messages, but only thanks to Ivan, I finally realized where I had to look.

Essentially the ext-biblatex styles are only supported by TeX Live versions from 2018-03-08 onwards which was the public release date of the biblatex-ext package. As I was using TeX Live 2017 in my online LaTeX editor shareLaTeX, the defined ext style could not be found. Quickly changing the setting to use a later TeX Live version (2020.1 in my case), everything worked as expected!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.