6

For some reason I'm unaware of, every *latex executable I've used has the strange habit of wrapping its console output at 78 columns. That's a bit surprising, since it always either ends up on a terminal or in a log file, and it's annoying, because more often than not it breaks long file names, that I could otherwise read (or parse) on a single line.

Is there a way to disable that?

3
  • 1
    yes, you can change the value in texmf.cnf (assuming texlive). Commented Mar 13, 2021 at 19:39
  • 6
    you have bought a wide teletype with more than 80 columns to connect to your mainframe? Commented Mar 13, 2021 at 19:43
  • @DavidCarlisle crazy, right? It even supports more than 2 different background colors! (correct me, but even for a VT100, the OS would've broken lines as necessary, I think the likeliest explanation is "printing tex errors to line printers", but I honestly can't imagine a use case for that – even 40 years ago.) Commented Mar 13, 2021 at 20:51

1 Answer 1

9

The default texmf.cnf has

% It's probably inadvisable to change these. At any rate, we must have:
% 45 < error_line      < 255;
% 30 < half_error_line < error_line - 15;
% 60 <= max_print_line;
% These apply to TeX, Metafont, and MetaPost.
error_line = 79
half_error_line = 50
max_print_line = 79

so you can set these in your local texmf.cnf (or as environment settings) oe on the command line -cnf-line=max_print_line=254

5
  • 1
    Thanks! This is a "uff, no, but you can at least have 254 instead of 78." This is, mildly put, a bit backwards :) I can see how a piece of software wouldn't want to accumulate arbitrarily large buffers for output, but err, < 256 characters, that can't be that hard for a system running TeX of all things! Commented Mar 13, 2021 at 20:54
  • Thank you for that perspective! Commented Mar 13, 2021 at 21:12
  • 1
    The setting can also be extended on the command line: -cnf-line=max_print_line=254 Commented Mar 13, 2021 at 21:20
  • ah, interesting, @HeikoOberdiek! Commented Mar 13, 2021 at 21:52
  • 1
    For the interested reader: I'm using max_print_line=200000 without problem now, Commented Mar 13, 2021 at 21:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .