1

I'm trying to use a TrueType Font with Texlive (3.14159265-2.6-1.40.20 (TeX Live 2019/Debian)) via autoinst on Ubuntu 20.04. Even though autoinst creates all the files and shapes correctly I still can't get the different font shapes to work and get the following error.

LaTeX Font Warning: Font shape `T1/OpenSans/m/it' undefined
LaTeX Font Warning: Some font shapes were not available, defaults substituted.

To illustrate the problem I use Open Sans (available here: https://fonts.google.com/specimen/Open+Sans?preview.text_type=custom). When I run

sudo autoinst *.ttf

in the download folder, autoinst runs as expected. The log-file looks like this:

[2021-03-19 17:16:28]  /usr/bin/autoinst, version 20200129

    "/usr/bin/autoinst OpenSans-Bold.ttf OpenSans-ExtraBold.ttf OpenSans-LightItalic.ttf OpenSans-SemiBoldItalic.ttf OpenSans-BoldItalic.ttf OpenSans-ExtraBoldItalic.ttf OpenSans-Italic.ttf OpenSans-Light.ttf OpenSans-Regular.ttf OpenSans-SemiBold.ttf"

----------------------------------------------------------------------------

I'm using the following options:

    encoding(s):        OT1, LY1, T1
    NFSS:               sf (sanserif)

    lining:             yes
    oldstyle:           yes
    proportional:       yes
    tabular:            yes
    ts1:                yes
    smallcaps:          yes
    swash:              yes
    titling:            yes
    superiors:          yes
    inferiors:          none
    ornaments:          yes
    fractions:          no
    ligatures:          yes

    auto/manual:        auto
    target:             /home/ird/Downloads/OpenSans/autoinst_output
    extra:              

    figurekern:         keep
    mergewidths:        yes
    mergeweights:       yes
    mergeshapes:        yes

    nfssweight:         
    nfsswidth:          

    


----------------------------------------------------------------------------

NFSS mappings:

    ul  =>  
    el  =>  
    l   =>  light
    sl  =>  
    m   =>  regular
    sb  =>  semibold
    b   =>  bold
    eb  =>  extrabold
    ub  =>  

    uc  =>  
    ec  =>  
    c   =>  
    sc  =>  
    m   =>  regular
    sx  =>  
    x   =>  
    ex  =>  
    ux  =>  

Copying the created folders to my working texmf-dist folder and running sudo texhash and sudo updmap -sys I can run pdflatex on the following file

\documentclass[a4paper]{article}
\usepackage[utf8]{inputenc}
\usepackage{OpenSans}

\begin{document}

This is supposed to be Open Sans, but is Computer Modern.

I can change the font manually by {\fontfamily{OpenSans}\selectfont to be OpenSans.}

But I can make it {\fontfamily{OpenSans}\fontshape{it}\selectfont to be italic.}

\end{document}

The errors I'm getting are


LaTeX Font Warning: Font shape `T1/OpenSans/m/n' undefined
(Font)              using `T1/cmr/m/n' instead on input line 11.


LaTeX Font Warning: Font shape `T1/OpenSans/m/it' undefined
(Font)              using `T1/OpenSans/m/n' instead on input line 13.

(/usr/share/texlive/texmf-dist/tex/latex/bera/t1fvs.fd) (/usr/share/texlive/texmf-dist/tex/latex/psnfss/t1pbk.fd) [1{/var/lib/texmf/fonts/map/pdftex/updmap/pdftex.map}] (./General_Notes.aux)

LaTeX Font Warning: Some font shapes were not available, defaults substituted.

Any pointers what is going here and what I'm doing wrong? It seems like the OpenSans.sty file isn't working, but Latex isn't complaining or throwing any other errors.

Many thanks!

2
  • where is T1opensans.fd and what is its content? Mar 19, 2021 at 19:39
  • Thanks Ulrike for getting back.
    – Ingo
    Mar 20, 2021 at 6:28

1 Answer 1

0

Thanks Ulrike for getting back. There isn't really a T1openssans.fd created in the process but files that are called T1OpenSans-LF.fd or similar and are located in /usr/share/texlive/texmf-dist/tex/latex/OpenSans/T1OpenSans-OsF.fd

enter image description here

The contents of T1OpenSans-LF.fd look like this:

%% Generated by autoinst on 2021/03/20
%%
\ProvidesFile{T1OpenSans-LF.fd}
    [2021/03/20 (autoinst)  Font definitions for T1/OpenSans-LF.]

\expandafter\ifx\csname OpenSans@scale\endcsname\relax
    \let\OpenSans@@scale\@empty
\else
    \edef\OpenSans@@scale{s*[\csname OpenSans@scale\endcsname]}%
\fi

\DeclareFontFamily{T1}{OpenSans-LF}{}

\DeclareFontShape{T1}{OpenSans-LF}{l}{n}{
      <-> \OpenSans@@scale OpenSans-Light-lf-t1
}{}

\DeclareFontShape{T1}{OpenSans-LF}{l}{it}{
      <-> \OpenSans@@scale OpenSans-LightItalic-lf-t1
}{}

\DeclareFontShape{T1}{OpenSans-LF}{l}{sl}{
      <-> ssub * OpenSans-LF/l/it
}{}

\DeclareFontShape{T1}{OpenSans-LF}{eb}{n}{
      <-> \OpenSans@@scale OpenSans-ExtraBold-lf-t1
}{}

\DeclareFontShape{T1}{OpenSans-LF}{eb}{it}{
      <-> \OpenSans@@scale OpenSans-ExtraBoldItalic-lf-t1
}{}

\DeclareFontShape{T1}{OpenSans-LF}{eb}{sl}{
      <-> ssub * OpenSans-LF/eb/it
}{}

\DeclareFontShape{T1}{OpenSans-LF}{sb}{it}{
      <-> \OpenSans@@scale OpenSans-SemiBoldItalic-lf-t1
}{}

\DeclareFontShape{T1}{OpenSans-LF}{sb}{n}{
      <-> \OpenSans@@scale OpenSans-SemiBold-lf-t1
}{}

\DeclareFontShape{T1}{OpenSans-LF}{sb}{sl}{
      <-> ssub * OpenSans-LF/sb/it
}{}

\DeclareFontShape{T1}{OpenSans-LF}{m}{n}{
      <-> \OpenSans@@scale OpenSans-Regular-lf-t1
}{}

\DeclareFontShape{T1}{OpenSans-LF}{m}{it}{
      <-> \OpenSans@@scale OpenSans-Italic-lf-t1
}{}

\DeclareFontShape{T1}{OpenSans-LF}{m}{sl}{
      <-> ssub * OpenSans-LF/m/it
}{}

\DeclareFontShape{T1}{OpenSans-LF}{b}{n}{
      <-> \OpenSans@@scale OpenSans-Bold-lf-t1
}{}

\DeclareFontShape{T1}{OpenSans-LF}{b}{it}{
      <-> \OpenSans@@scale OpenSans-BoldItalic-lf-t1
}{}

\DeclareFontShape{T1}{OpenSans-LF}{b}{sl}{
      <-> ssub * OpenSans-LF/b/it
}{}

\DeclareFontShape{T1}{OpenSans-LF}{bx}{sl}{
      <-> ssub * OpenSans-LF/b/sl
}{}

\DeclareFontShape{T1}{OpenSans-LF}{bx}{n}{
      <-> ssub * OpenSans-LF/b/n
}{}

\DeclareFontShape{T1}{OpenSans-LF}{bx}{it}{
      <-> ssub * OpenSans-LF/b/it
}{}

\endinput
1
  • I actually have not tried on Ubuntu 18.04 and everything works like a charm. Has anyone experienced issues with autoinst created fonts on 20.04?
    – Ingo
    Mar 22, 2021 at 14:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .