I am writing my thesis in law using biblatex-chicago. We are writing in Danish and when citing articles, books etc. we are using the postnote to indicate the specific page, section etc.

When citing @books using \autocite, the reference in the footnote has no prefix in the postnote, but when citing @jurisdiction, @legislation and @legal it prints "at" as the prefix in the postnote.

I have tried using \DeclareFieldFormat{postnote}{#1} and \DeclareFieldFormat{multipostnote}{#1} but it does not seem to work.

How do I omit prefixes in the postnote of these entry types?

  • 1
    Please accept the answer (if it suits for you) by clicking the tick mark
    – MadyYuvi
    Commented Dec 20, 2022 at 3:32

1 Answer 1


biblatex-chicago is an extremely complicated style bundle, because it tries to implement the requirements of the Chicago Manual of Style as closely as possible with biblatex. As such it can be fairly difficult to modify biblatex-chicago to deviate from CMoS requirements. Some changes need lots of code, others have the potential to break desired behaviour in unexpected places.

As such I cannot guarantee that the following code does not have unintended side-effects; doubly so because there is no example document (MWE: I've just been asked to write a minimal working example (MWE), what is that?) in the question.


Your \DeclareFieldFormat{postnote} did not work, because biblatex-chicago uses type-specific formats to typeset the postnote field, but \DeclareFieldFormat{postnote} only changes the non-type-specific format. You could have used the starred version \DeclareFieldFormat*{postnote}

\DeclareFieldFormat*{postnote}{% Changed for page compression option
    togl {cms@comprange}%
    test {\ifpages{#1}}%

to get rid of all type-specific formats first. (For more examples on type-specific format, see Remove Quotation Marks from Style)

  • Thank you very much - it worked. I am new to overleaf and coding in general :) Commented Mar 29, 2021 at 8:05
  • 1
    @MarieAdserballeKristensen If the answer helped you solve your problem, please consider accepting the answer to show that the question is resolved. See tex.stackexchange.com/help/someone-answers.
    – moewe
    Commented Mar 29, 2021 at 12:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .