0

I’ve tried to adjust the bibliography list and inline citations using my Bibdesk programme. Therefore I’ve already consulted several sources and questions in the stackexchange but just can’t achieve the bibliography style as wanted by my professor. I know I have to change the different source types like book or incollection separately though I’d need help with incollection or online sources (I’m not even sure which source type I should take for online sources, Bibdesk offers me "url", "electronic" or "webpage").enter image description here

In a nutshell: How do I get

  • the incollection style as it is shown above with "Author (Year): ‚‚Title", In: surname of editor 1, first name of editor 1 / surname of editor 2, first name of editor 2 (Hg.): Booktitle. Address: Publisher." respecting all the punctuation signs and "(Hg.)"
  • the style of the online sources "… URL: [dd.mm.yyyy]." like in Dethloff oder Educlever (above)

I’ve really tried a long time but there were always problems and it just didn’t work out. Could somebody help me? (Many answers to questions I’ve seen have somewhere included apa oder apastyle – ANYTHING with apa doesn't work with my TeXShop.)

2
  • (1) Are you using bibtex or biblatex? You tagged both but they have different configuration methods. If you need to design a bibliography style from scratch, it is a lot easier IMHO to do it using biblatex than bibtex. (2) You only specified the "incollection" style and the "online" style. What about the styles for other types of sources? Does your professor specify a "common" citation style that people can build off of? (3) The "apa doesn't work with my TeXShop" is a problem. You should try to get that solved. Mar 26, 2021 at 14:02
  • Welcome to TeX.SE. Your question is currently a bit difficult to answer, some more details are needed. Could you add a small example LaTeX document to your question, that results in your current output? It should not contain any 'normal' content, just the documentclass, packages and settings related the the bibliography, and one or two example references. You can add code to your question by pressing the edit button at the bottom. Also it would be interesting to know what you mean by 'anything with APA doesn't work', what did you try, which errors do you get?
    – Marijn
    Mar 26, 2021 at 14:03

1 Answer 1

1

Note that your requirements are inconsistent: in Erstic the "In" is capitalised, in Dethloff it isn't. Furthermore, the example entries are by far not enough to construct a complete biblatex style

The following should get you started.

We are using ext-authoryear as basis, because its innamebeforetitle and innameidem options (see the biblatex-ext documentation) can get use to the desired format for @inbook and @incollection entries fairly quickly.

The remaining changes are routine modifications. The names of the involved commands should make it reasonably clear what each line does (especially if you Ctrl+F for things you don't understand at first in the biblatex documentation). But if you have any question, don't hesitate to comment below.

\documentclass[ngerman]{article}
\usepackage[T1]{fontenc}
\usepackage{babel}
\usepackage{csquotes}

\usepackage[
  backend=biber,
  style=ext-authoryear,
  innamebeforetitle=true,
  innameidem=true,
]{biblatex}

\DeclareNameAlias{sortname}{family-given}
\DeclareNameAlias{ineditor}{sortname}

\DeclareDelimFormat[bib]{multinamedelim}{\addspace\slash\space}
\DeclareDelimAlias[bib]{finalnamedelim}{multinamedelim}

\DeclareFieldFormat{editortype}{\mkbibparens{#1}}
\DeclareDelimFormat{editortypedelim}{\addspace}
\DeclareFieldAlias{translatortype}{editortype}
\DeclareDelimAlias{translatortypedelim}{editortypedelim}

\DeclareDelimFormat[bib]{nametitledelim}{\addcolon\space}

\renewbibmacro*{in:}{%
  \setunit{\addcomma\space}%
  \bibstring{in}%
  \printunit{\intitlepunct}}

% \urlstyle{same}
\DeclareFieldFormat{url}{<\url{#1}>}
\DeclareFieldFormat{urldate}{\mkbibbrackets{#1}}

\DefineBibliographyStrings{german}{
  editor  = {Hg\adddot},
  editors = {Hg\adddot},
}

\addbibresource{biblatex-examples.bib}

\begin{document}
Lorem \autocite{ctan,westfahl:space}

\printbibliography
\end{document}

CTAN (2006): CTAN. The Comprehensive TeX Archive Network. http://www.ctan.org [01.10.2006].//Westfahl, Gary (2000): „The True Frontier. Confronting and Avoiding the Realities of Space in American Science Fiction Films“, in: Ders. (Hg.): Space and Beyond. The Frontier Theme in Science Fiction. Westport, Conn. und London: Greenwood, S. 55–65.

6
  • Thank you a lot for your help! Everything except \DeclareDelimAlias[bib]{finalnamedelim}{multinamedelim} (1) has worked fine. As to (1): LaTeX tells me "./documentname.tex:31: LaTeX Error: Missing \begin{document}" and in the following "(1) ?". I would like to share you my preamble but therefore I don’t have enough characters in this comment (I’m sorry, this is my first question asked). So I tried your commands without (1) and one thing doesn't fit: When there are >1 editors (incollection), there is no comma between the surname and the first name of editor 1 (maybe it has to do with (1)). Mar 27, 2021 at 15:11
  • Maybe it is also important to type the editors correctly into Bibdesk? I always do it like this: surname 1, first name 1 / surname 2, first name 2 … And I forgot to ask: Which type of source (in Bibdesk) do you recommend me to use for online sources? Mar 27, 2021 at 15:15
  • @GustaveFlaubert If \DeclareDelimAlias[bib]{finalnamedelim}{multinamedelim} does not work, your biblatex is very likely too old. If possible consider updating your TeX system. If that is not possibly you could try \DeclareDelimAlias*[bib]{finalnamedelim}{multinamedelim} which might work if your system is not too old, but is deprecated now.
    – moewe
    Mar 27, 2021 at 16:04
  • @GustaveFlaubert The input editor = {surname 1, first name 1 / surname 2, first name 2}, is wrong. Regardless of the desired output, you must separate all names in the input with and, so you want editor = {surname 1, first name 1 and surname 2, first name 2}, here (e.g. editor = {Colli, Giorgio and Montinari, Mazzino},, see also tex.stackexchange.com/q/36396/35864). The correct entry type for online resources in biblatex is @online (@electronic is a backwards compatibility alias for @online). But I don't use Bibdesk, so don't know which types it supports.
    – moewe
    Mar 27, 2021 at 16:05
  • Thank you for everything! I really appreciate that you’ve taken the time for my questions. Mar 28, 2021 at 12:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .