5

I have spent a considerable amount of time trying to show Pᗣᗧ•••MᗣN (defined https://en.wikipedia.org/wiki/Unified_Canadian_Aboriginal_Syllabics_(Unicode_block)) within a Beamer (or any other document class) document using XeLaTeX, but to no avail. I have tried different ways shown in other questions, but nothing seems to work. The example file below is saved as UTF-8.

Does anyone know how to get this to work?

\documentclass{beamer}

% \usepackage[T1]{fontenc}
% \usepackage{fontspec}
% \usepackage[utf8]{inputenc}  % pdflatex
% \usepackage[utf8x]{inputenc}  % pdflatex, not recommended

% \DeclareUnicodeCharacter{2014}{\dash}
% \DeclareUnicodeCharacter{15E3}{ᗣ}

% \usepackage{newunicodechar}
% \newunicodechar{ᗣ­}{\pacman}

% \char"15E3

\begin{document}
Pᗣᗧ•••MᗣN
\end{document}
4

Here is a version that uses beamer and allows you to set the main font to whatever you want.

\documentclass{beamer}
\tracinglostchars=2
\usepackage{fontspec}
\usepackage{newunicodechar}

% Aboriginal Sans is available at:
% http://www.languagegeek.com/font/fontdownload.html#Full_Unicode
\newfontfamily\ASfont{Aboriginal Sans}[Scale=MatchUppercase]
\newunicodechar{ᗣ}{{\ASfont ᗣ}}
\newunicodechar{ᗧ}{{\ASfont ᗧ}}

\begin{document}
Pᗣᗧ•••MᗣN
\end{document}

sample

You would only use inputenc and its \DeclareUnicodeCharacter command in PDFTeX.

Edit

I’d forgotten that Aboriginal Sans is not part of the TeX Live distribution. You can get a list of the fonts on your system that support this code block with the command

albatross "0x15e3" 
4
  • This seemed to work after downloading and installing that font from somewhere online. Thanks! – dfernan Apr 2 at 12:54
  • @dfernan edited to provide a link to the font, as well as the command to list all the fonts on your system that support a given character. – Davislor Apr 2 at 14:58
  • Thanks @davislor. Apparently albatross requires Java. Do you happen to know an alternative utility? – dfernan Apr 2 at 15:09
  • @dfernan Installing the JVM on the command-line without enabling it for your browser should be safe, but there’s also a tool at fileformat.info. – Davislor Apr 2 at 16:28
6

You just need a suitable font. My browser used Gadugi to show your question so I used the same.

enter image description here

\documentclass{article}

\usepackage{fontspec}

\setmainfont{Gadugi}
\begin{document}
Pᗣᗧ•••MᗣN
\end{document}

5
  • 2
    I think this answer could be improved by noting the line in the output log of XeLaTeX where it complains about the missing characters. Most people are overwhelmed by the... slightly chaotic nature of LaTeX log files, and this furthers understanding. – ljrk Apr 2 at 8:47
  • That font did not seem to work for me after downloading and installing it from somewhere online. Is there a reliable source to download that font from? The answer from @davislor seemed to work, though! – dfernan Apr 2 at 12:53
  • @dfernan I didn't mean for you to get that font, but rather see which font your browser uses (right menu inspect, usually) but if the other answer worked then this answer would work if you used Aboriginal Sans instead of Gadugi – David Carlisle Apr 2 at 13:52
  • Still does not seem to work without explicitly defining the Unicode characters with \newunicodechar. – dfernan Apr 2 at 14:50
  • @dfernan what are you defining them to? If they work then they work if they don't work then there is no working definitiion that you can define. You should definitely not need newunicodechar here. – David Carlisle Apr 2 at 15:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.