0

I have a .bib file with entries like this:

@article{abdulkadirouglu2015expanding,
  title={Expanding {`choice'} in school choice},
  author={Abdulkadiro{\u{g}}lu, Atila and Che, Yeon-Koo and Yasuda, Yosuke},
  journal={American Economic Journal: Microeconomics},
  volume={7},
  number={1},
  pages={1--42},
  year={2015}
}

With references in LyX turning out as shown below. I'm happy with it except for the "In". citation example

It's not clear to me how to suppress this "In," and I'm not sure how to adapt solutions like these.

My bibliography settings (>Document/Settings/Bibliography) are Style format: Biblatex, Variant: Author-year, the citation and bibliography style is authoryear. I am running LyX 2.3.6.1. Thanks for the help!

1 Answer 1

0

Assuming you only want to suppress the "in:" for @article entries I suggest you adapt my answer to Suppress "In:" biblatex.

This means that in the Documents > Settings > Bibliography settings you need to choose the biblatex-ext style that corresponds to your biblatex standard style. So instead of authoryear you pick

ext-authoryear

in Biblatex citation style and Biblatex bibliography style (red circles in screenshot below, you can use the Match button to set the bibliography to the same style as the citation style).

Then you add

articlein=false,

to the Options (green circle).

Screenshot of LyX document options with authoryear-ext selected as bibliography and citation style and articlein=false, option set

Press OK and recompile your document to obtain

Sigfridsson, Emma and Ulf Ryde (1998). “Comparison of methods for deriving atomic charges from the electrostatic potential and moments”. Journal of Computational Chemistry 19.4, pp. 377–395. doi: 10.1002/(SICI)1096-987X(199803)19:4<377::AID-JCC1>3.0.CO;2-P.

from a simple document citing biblatex-examples's sigfridsson entry.

2
  • Is there a way to do this for general entries, too? I.e., if I have misc, techreport's, etc? It looks like biblatex-ext only offers this option for articles.
    – shaha
    Apr 6, 2021 at 15:26
  • @shaha For @misc and @techreport there shouldn't be an "in:" in the first place. And for entry types beside @article that normally have an "in:" (@inbook, @incollection, @inproceedings) you generally want to retain the "in:". As I say in my linked answer, if you want to get rid of "in:" for all types, you need a different approach, but really I don't think you need/want that.
    – moewe
    Apr 6, 2021 at 15:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .