1

I moved to a new machine and can't get texify to work. Everything else works - I can use PDFLaTeX to run the .tex document, run biber, then PDFLaTeX repeatedly to get the desired PDF. But PDFLaTeXify gives me the error "object 'errorstopmode' not found."

Options: Execution modes: Diagnosis says my Miktex installation appears to be fine.

Any suggestions?

I'm running Winedt v 10.3, build 20180507. LaTeXify is installed and up to date.

Thanks! Gordon

Here are the settings for PDFTeXify. Are any others needed?

enter image description here

This setup allows me to use knitr directly in WinEdt, to edit/compile .Rnw documents (combination R code and output + LaTeX). One source for this instruction is https://yihui.org/knitr/demo/editors/.

But perhaps that's outmoded. I see that the RManager plugin has no such instructions. Maybe I should experiment resetting this to the default settings. Do you know what they are?

Well, that was a silly request. I see how to reset to default - and it's now more or less working. Doesn't seem to actually run Biber but I'll fool around a bit - at least I'm on the road to getting it fixed!

5
  • can you run it on a command line? Apr 7 at 8:00
  • No. Is there supposed to be a latexify or pdflatexify executable somewhere? Or am I missing the point of your question (I'm assuming you mean something like [pdf]latexify myfile.tex)?
    – gfox
    Apr 8 at 23:13
  • Both latex myfile.tex and texify --pdf myfile.tex do run fine from the command line.
    – gfox
    Apr 8 at 23:35
  • Then you will have to show the relevant winedt settings. Apr 9 at 6:01
  • Well you seem not to use texify but RScript.exe, but I can't tell you how you got there and if this makes sense. Apr 9 at 17:22
0

For anyone else that runs into this problem (PDFLaTeXify not running due to setup w/ RManager), it's actually a simple fix: forget the ancient settings. Things will now run close to out of the box. Settings that are now working for me are below.enter image description here

And these for Biber to run automatically as part of the process. enter image description here

Many thanks to Ulrike Fischer for setting me on the road towards the solution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.