2

I am using BibTeX and the bibliography style alpha. One of my bibliohraphy entries has as many as 7 authors. I would like to have them all listed in the bibliography. I have made the following bibtex entry:

@Book{Gemoll,
  title     = {Gemoll, griechisch-deutsches Schul- und Handwörterbuch},
  publisher = {Oldenbourg},
  year      = {2019},
  author    = {Therese Aigner and Josef Bedrac and Renate Oswald and Jörg Schönbacher and Clemens Schuster and Rudolf Wachter and Franz Winter},
}

Unfortunately, this yields the following result: enter image description here

I would like there to be no "and" in the bibliography and have the names only seperated by commas. Can someone help me to achieve this?

Here is a MWE:

\documentclass[12pt]{article}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[ngerman, greek]{babel}
\usepackage{hyperref}
\usepackage[a4paper, width=160mm,top=20mm,bottom=20mm, bindingoffset=6mm]{geometry}

\usepackage[cmintegrals,cmbraces]{newtxmath}
\usepackage{ebgaramond-maths}

\begin{document} \selectlanguage{ngerman}
\cite{Gemoll}
\bibliography{Biblio_UE}
\bibliographystyle{alpha}

\end{document}
4
  • Can you give some more details on your bibliography style and implementation method (packages etc), ideally in an MWE? This issue may possibly be solved by using an alternative bib-style, but it is hard to tell how this could be implemented in your use-case. – Markus G. Apr 6 at 13:35
  • I am unsure how to generate an MWE since my document is quite large. I am using the style alpha. What else would you like to know exactly? – rensemil Apr 6 at 13:39
  • Well, the packages you are using that are related to the bibliography would be helpful, e.g. are you using the biblatex package etc. For an MWE really only those and an empty document with your sample bibliography would actually suffice, since the entire rest of your document is unrelated to your question. – Markus G. Apr 6 at 13:45
  • I have added an MWE. The bib file Biblio_UE contains the bibliography, including the entry ia wrote above. – rensemil Apr 6 at 13:50
4

bst files are quite hard coded, so the only way to do this with bibtex is to make a copy of alpha.bst, change its name, and edit it.

On my system the command

> kpsewhich alpha.bst

returns

/usr/share/texmf/bibtex/bst/base/alpha.bst

Now copy this file in the current working directory or in your local texmf tree, change its name to e.g. alpha-noand.bst, and look for occurrences of " and " (line 203 for authors, in my case), and change this to " ".

Put into context this occurs within the definition of the function format.names

FUNCTION {format.names}
{ 's :=
  #1 'nameptr :=
  s num.names$ 'numnames :=
  numnames 'namesleft :=
    { namesleft #0 > }
    { s nameptr "{ff~}{vv~}{ll}{, jj}" format.name$ 't :=
      nameptr #1 >
        { namesleft #1 >
            { ", " * t * }
            { numnames #2 >
                { "," * }
                'skip$
              if$
              t "others" =
                { " et~al." * }

(now the edited line -- before the edit it was { " and " * t * })

                { " " * t * }

(the rest remains unchanged)



              if$
            }
          if$
        }
        't
      if$
      nameptr #1 + 'nameptr :=
      namesleft #1 - 'namesleft :=
    }
  while$
}

Then of course use

\bibliographystyle{alpha-noand}

in your document.


Complete example:

\begin{filecontents*}{Biblio_UE.bib}
@Book{Gemoll,
  title     = {Gemoll, griechisch-deutsches Schul- und Handwörterbuch},
  publisher = {Oldenbourg},
  year      = {2019},
  author    = {Therese Aigner and Josef Bedrac and Renate Oswald and Jörg Schönbacher and Clemens Schuster and Rudolf Wachter and Franz Winter},
}
\end{filecontents*}

\documentclass[12pt]{article}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[ngerman, greek]{babel}
\usepackage{hyperref}
\usepackage[a4paper, width=160mm,top=20mm,bottom=20mm, bindingoffset=6mm]{geometry}

\usepackage[cmintegrals,cmbraces]{newtxmath}
\usepackage{ebgaramond-maths}

\begin{document} \selectlanguage{ngerman}

\cite{Gemoll}
\bibliography{Biblio_UE}
\bibliographystyle{alpha-noand}

\end{document}

enter image description here

6
  • Thank you for the answer. However, I do not understand where to find the alpha.bst file. And: what do you mean by "your local texmf tree". I apologize, I am not exactly an expert in LaTeX. – rensemil Apr 6 at 14:05
  • 1
    @rensemil As I wrote above kpsewhich in the command line will output the exact path, otherwise just search for the file in your computer. Ignore the bit about the local texmf tree, just copy and edit the file in your current working directory. – campa Apr 6 at 14:08
  • Thanks a lot. I have done this but now I get the following error message when compiling my latex file (which is called Portfolio.tex): I couldn't open style file alpha-noand.bst ---line 184 of file Portfolio.aux : \bibstyle{alpha-noand : } I'm skipping whatever remains of this command – rensemil Apr 6 at 14:20
  • @rensemil I can't really say anything without seeing the exact code... Is the modified bst file in the same directory as your tex file? – campa Apr 6 at 14:24
  • What code do you need exactly? I have made exactly the changes you suggested. The modified file is in the same folder as the original alpha.bst file. Should I put it in the folder of the actual .tex file? – rensemil Apr 6 at 14:25
1

Try using biblatex (biber) instead of bibtex. This works (I ran pdflatex <filename.tex> 2 times then biblatex then pdflatex again 2 times).

\documentclass[12pt]{article}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[ngerman, greek]{babel}
\usepackage{hyperref}
\usepackage[a4paper, width=160mm,top=20mm,bottom=20mm, bindingoffset=6mm]{geometry}

\usepackage[cmintegrals,cmbraces]{newtxmath}
\usepackage{ebgaramond-maths}

%Using biblatex (biber) instead of bibtex
\usepackage[backend=biber, citestyle=numeric, maxbibnames=99]{biblatex}
\addbibresource{Biblio_UE.bib}

\renewcommand*{\finalnamedelim}{\addcomma\addspace}
\addbibresource{\jobname.bib}

\begin{document} \selectlanguage{ngerman}
\cite{Gemoll}

%Disabled because now using biblatex
%\bibliography{Biblio_UE}
%\bibliographystyle{alpha}

\printbibliography

\end{document}

enter image description here

Inspired by Mico, #193388

3
  • This, for some reason, does not work. The produced pdf file only contains [Gemoll]. Nothing else. There is also the issue of missing spaces after the commas in the bibliography entry. – rensemil Apr 6 at 14:24
  • @rensemil Perhaps running pdflatex <filename.tex> 2 times (before and after biblatex) helps (edited in my answer). – ubuntuuser Apr 7 at 11:39
  • @rensemil For a bigger space after the commas you can insert \renewcommand*{\multinamedelim}{\addcomma \;\addspace} in preamble, e. g. after \addbibresource{Biblio_UE.bib} See the biblatex documentation https://ctan.org/pkg/biblatex (available in english and in german) – ubuntuuser Apr 7 at 11:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.