0

I'm using KOMA's scrartcl document to create a short paper where I've included some references. I'm using

\bibliographystyle{unsrt}
\bibliography{references}

at the end to print the bibliography. Unfortunately, a field called tex.ids:... keeps appearing.

How can I remove that field for every entry?

I have tried using

\usepackage[
   backend=biber,
   style=alphabetic,
]{biblatex}
\addbibresource{references}

but I have errors about not being able to find the bibliography.

I'm using Overleaf.

4
  • 1
    Please provide a MWE (minimal working example) following the demands you find here: tex.meta.stackexchange.com/q/228/231952, so that we can better understand the problem you are encountering. For the creation of a MWEB (minimal working example with Bibliography) see also: tex.meta.stackexchange.com/a/4408/231952
    – Ivan
    Apr 6 at 17:47
  • 1
    Have you tried changing \addbibresource{references} to \addbibresource{references.bib}?
    – Mico
    Apr 6 at 18:24
  • 2
    Please edit your posting to show an entry that has a field called tex.ids.
    – Mico
    Apr 6 at 18:25
  • Generally bibliography styles (no matter if BibTeX or Biber) will ignore fields they don't know. Off the top of my head I'm not aware of any style that knows tex.ids, so something else is going on. Presumably the tex.ids data is exported into some field that is known and does get printed, but without an example of a .bib entry, it's impossible to help properly.
    – moewe
    Apr 6 at 21:24
0

The problem was that the tex.ids field wasn't a field per se but the text inside the notes.

It appears from the Zotero export (I import the bibliography into Overleaf from Zotero), but it doesn't appear in the Zotero app. After looking at the .bib file, I saw that it was in the note fields.

The solution I took first was to remove every non-useful field when setting the biblatex package options.

\usepackage[backend=bibtex,%
    style=numeric,%
    sorting=none,%
    giveninits=true,%
    eprint=false,%
    url=false,doi=false,isbn=false]{biblatex}

Finally, I used the commands below in the preamble to clear the notes field at every item in the bibliography-

\AtEveryBibitem{%
    \clearfield{note}%
}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.