3

My Texmaker with MikTex setup have been working without problems for years, but I had to reinstall MikTex for it to recognise a new package I wanted to use.

After reinstallation everything worked fine, but after a restart of the computer I get a error when compiling in Texmaker:

"Could not start command. pdflatex -synctex=1 -interaction=nonstopmode %.tex"

With the further detail in the log: "pdflatex: Bad parameter value. pdflatex: Data: font_mem_size"

I didn't find any solutions to this problem out there, so I decided to reinstall both MikTex and Texmaker to test if something went wrong with the installation. After that it worked again, but only until I restart the computer.

I read a bit about the "font_mem_size", but from my limited understanding of it I have a hard time believing it really is related to this parameter. I would rather think it is related to a PATH issue, but I can't figure out how.

A copy of my configuration: enter image description here

I am able to compile documents directly in MikTeX (through TeXworks). Both TeXMaker and TeXStudio produce the same error.

In MiKTeX I constantly have a PATH issue "This directory is not in the search path for executables or it is at the wrong position in the path. You can fix this issue by adding the directory to the environment variable PATH. This makes it possible to invoke the MiKTeX executables everywhere". The issue disappears when I press "Fix now", but reapers when I restart MiKTeX. I added the path to the executables mentioned in the PATH issue in MeKTeX Console to PATH in my Texmaker configuration. This didn't change anything.

UPDATE:

Using TeXLive instead of MiKTeX solved the problem.

2 Answers 2

0

I have the same problem, and Found the "final" solution:

RUN AS ADMINISTRATOR

It took me many years to solve it...

-1

I have the same problem, and Found the "final" solution:

RUN AS ADMINISTRATOR

It took me many years so solve it...

4
  • 6
    Welcome. // Can you please give a code example, how you disable babel? Would make your answer more complete and more valuable for other reader,
    – MS-SPO
    Commented Oct 16, 2022 at 8:36
  • Siply open the code, put % in front: %\usepackage{babel} compile, then use some mora advanced tools like LyX or another Latex editor to read/clean errors. Than save in plain LaTeX and crossfinger you can again work on it. I've the same problems with MiKTeXt. Some times it is just question of a missing "{" in a formula... Commented Oct 17, 2022 at 12:15
  • I'm again with the same problem: also deleting the .aux files (it works some times just) after running lyrix importing and exporting the same fle under another name... I'm now forced to use another PC... If someone has better suggestion... W7 x64... thanks ! Commented Sep 10, 2023 at 15:22
  • Found the final solution: RUN AS ADMINISTRATOR Commented Oct 26, 2023 at 5:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .