2

I want to have control over where the frame breaks. This is my first beamer presentation I am creating , yet I couldn't find an answer to my problem.

Consider the following MWE:

\documentclass{beamer}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[english]{babel}
\title{MEW}

\begin{document}
\section{Intro}
\begin{frame}[allowframebreaks,noframenumbering,fragile]{Theoretical Introduction}
Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat.
\framebreak
Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.
\end{frame}
\end{document}

The output is this:

Frame break not at the desired location

I want the second frame to start with

Duis aute irure dolor in ...

For some reason TeX decided to break it at "reprehenderit in voluptate...".

How can I tell Beamer and TeX to break the frame where I decided to put \framebreak?

Another question: Isn't the option noframenumbering should suppress the appending of the roman numerals to the second (and possibly the following third and fourth) frames? It doesn't seem to have effect.

I am saying it again, I couldn't find an answer on tex.se about this issue.

Note: I compile the .tex file on Overleaf.

4
  • Why don't you simply replace \framebreak with \end{frame} \begin{frame}{Theoretical Introduction}?
    – leandriis
    Apr 11, 2021 at 10:52
  • @leandriis That's right, but what if I decide in a later stage of the writing to change "Theoretical background" to "Introductory remarks"? I would have to change all the frame titles one by one.
    – tush
    Apr 11, 2021 at 10:54
  • noframenumbering tells beamer to not step the framenumber counter for this particula frame, which in turn is often output in the footer of a frame. To get rid of the roman number behind the frame title, you would use \setbeamertemplate{frametitle continuation}{} instead.
    – leandriis
    Apr 11, 2021 at 10:56
  • You could store the actual frame title such as "Theoretical background" inside of a command: \newcommand{\introframetitle}{Theoretical Introduction} and reuse the command in your frames: \begin{frame}{\introframetitle}. If you later on decide to change the frame title to something else, just change the definition, e.g. to \newcommand{\introframetitle}{Introductory remarks} and all your frames should adapt accordingly.
    – leandriis
    Apr 11, 2021 at 11:00

2 Answers 2

4

The beamer manual explicitly states

Do not use the option allowframebreaks except for long bibliographies.


I therefore suggest the following solution that uses to different frames in combination with a command that stores the shared frame title.

\documentclass{beamer}
\usepackage[english]{babel}

\begin{document}
\section{Intro}
\newcommand{\introframetitle}{Introductory remarks}
\begin{frame}{\introframetitle}
Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat.
\end{frame}

\begin{frame}{\introframetitle}
Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.
\end{frame}
\end{document}

If you prefer a solution that just uses a single frame, you could alternatively use overlays:

\documentclass{beamer}
\usepackage[english]{babel}

\begin{document}
\section{Intro}
\begin{frame}{Introductory remarks}
\only<1>{Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat.}

\only<2>{Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.}
\end{frame}
\end{document}
1
  • Since everyone all over this website and the manual explicitly says that, I would stick to the \newcommand{\titlename}{My Title Name} solution. It seems preferable. Thanks a lot!
    – tush
    Apr 11, 2021 at 11:58
2

With an additional \linebreak the second frame will start with

Duis aute irure

\documentclass{beamer}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[english]{babel}
\title{MEW}

\begin{document}
\section{Intro}
\begin{frame}[allowframebreaks,noframenumbering,fragile]{Theoretical Introduction}
Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat.
\framebreak\linebreak
Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.
\end{frame}
\end{document}

Page break

2
  • A simple empty line before or after \framebreak should result in the same output.
    – leandriis
    Apr 11, 2021 at 11:11
  • @luki Still, how can I suppress the roman numerals from the frames title?
    – tush
    Apr 11, 2021 at 12:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.