1

I am facing this problem where I can not update MikTeX 21.2 right after installation. I have uninstalled and reinstalled MikTeX to no avail. I do not have any apps open but my computer is connected to OneDrive when I updated. After I updated I can not compile my LaTeX files in TexStudio as it generates an error message. I saw a similar question here to mine but there was no definite answer, I think. Please do help

This is the error message that I get in MikTeX when I try to update.

fileName="C:\Users\bells\AppData\Local\Programs\MiKTeX\miktex\bin\x64\miktex-fc-cache.exe", exitCode="1"


GENERAL MIKTEX INFORMATION
ReportDate: 2021-04-15 16:10:27
CurrentVersion: 21.2
SetupDate: 2021-04-15 15:59:00
SetupVersion: 21.2
Configuration: Regular
GitInfo: 7a7e645 / 2021-02-20 10:38:14
OS: Windows 10 Home, 64-bit, build 19042
SharedSetup: no
LinkTargetDirectory: C:\Users\bells\AppData\Local\Programs\MiKTeX\miktex\bin\x64
PathOkay: no
LastUpdateCheck: 2021-04-15 16:00:30
LastUpdate: 2021-04-15 16:09:50
LastUpdateDb: 2021-04-15 16:00:22
SystemAdmin: yes
RootPrivileges: no
AdminMode: no
Root0: C:\Users\bells\AppData\Roaming\MiKTeX
Root1: C:\Users\bells\AppData\Local\MiKTeX
Root2: C:\Users\bells\AppData\Local\Programs\MiKTeX
Root3: C:\ProgramData\MiKTeX
Root4: C:\Program Files\MiKTeX
UserInstall: C:\Users\bells\AppData\Local\Programs\MiKTeX
UserConfig: C:\Users\bells\AppData\Roaming\MiKTeX
UserData: C:\Users\bells\AppData\Local\MiKTeX
CommonInstall: C:\Program Files\MiKTeX
CommonConfig: C:\ProgramData\MiKTeX
CommonData: C:\ProgramData\MiKTeX
Invokers: non-existing/cmd

ERROR DETAILS
Program: miktex-fc-cache.exe
Error: The executed process did not succeed.
Details: 
  fileName: C:\Users\bells\AppData\Local\Programs\MiKTeX\miktex\bin\x64\miktex-fc-cache.exe
  exitCode: 1
16
  • What do you get if you call fc-cache -v on a command line? Commented Apr 15, 2021 at 10:03
  • @Ulrike Fischer C:\Users\bells>fc-cache -v C:/WINDOWS/fonts: caching, new cache contents: 1154 fonts, 0 dirs C:/WINDOWS/fonts: failed to write cache C:/WINDOWS/Cache/Fontcache: not cleaning non-existent cache directory fc-cache: failed Commented Apr 15, 2021 at 11:58
  • C:/WINDOWS/Cache/Fontcache sounds very odd. Open an issue at the miktex github. Commented Apr 15, 2021 at 12:07
  • @Ulrike Fischer I realised that I had run the code you specified in command prompt when I had reinstalled MikTeX without updating the packages. Once I updated MiKTeX and ran the code you specified in command prompt, I got a whole lot of error messages in 4 dialog boxes saying code execution could not proceed because MikTex210200-app.dll, MikTex210200-getopt.dll, MikTex210200-fontconfig.dll, MikTex210200-core.dll was not found. Was advised to reinstall program Commented Apr 15, 2021 at 12:30
  • I had uninstalled and reinstalled but to no avail. It won't update without error Commented Apr 15, 2021 at 12:31

1 Answer 1

1

A few days ago I stumbled in the same problem (fc-cache returning an error every time I tried to update a package). looking the logs, the error seemed to be around c:\windows\Cache and c:\windows\Cache\Fontcache (which were non existent in my system), so I just created those (as administrator, note, my user account is a 'standard' one). the error message changed a bit, but remained. then, as an administrator, I gave my user account writing rights to those dirs (in fact, full access to just c:\windows\Cache). "problem solved" no more error messages from fc-cache. so, fc-cache wants/needs write access to c:\windows\Cache, which is not an issue if your user account has admin rights (which is a no-no for security reasons). MikTeX version 21.8

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .