0

I would like to use emerald fonts in my Beamer presentation (http://www.tug.dk/FontCatalogue/augie/)

As far I have understood, I have to download the emerald folder and to move the fonts in some other folder related to latex. In particular, it seems that I have to copy the directories "fonts" and "tex" to "~/Library/texmf/"

It works on my Mac OSX with MacTex installed as well. First, download the emerald zip file from ctan and unzip it. Second, copy the two dirs: fonts and tex to ~/Library/texmf/. The I should some staff as updmap and texhash.

First of all, I would like if the above mention procedure is correct for linux\ubuntu. Secondly, I would like how to locate the folder texmf in ubuntu. Lastly, Do you have other suggestion to install emerald.

This is the solution that I have found so fare:

\documentclass[]{beamer}
\usepackage{tikz}
\usepackage[T1]{fontenc}
\DeclareRobustCommand{\augiefamily}{%
  \fontfamily{augie}\fontseries{m}\fontshape{n}\selectfont}
\DeclareTextFontCommand{\textaugie}{\augiefamily}


\augiefamily

\begin{document}
 
 
\begin{frame}{\augiefamily Example}
 hello
\end{frame}
 

\end{document}

As you can notice, I skip "emerald.sty". Unfortunately , I have to add "\augiefamily" everywhere.

1 Answer 1

1

If you have a TrueType or OpenType font, and I believe Augie does come in this format, you can save it in any of your system or user font directories, and LuaTeX or XeTeX should be able to find it. If you’re writing a beamer presentation, no publisher is stopping you from using modern fonts or LuaTeX. That’s usually the simplest way.

I believe the latest TrueType version of Augie is still up at the Internet Archive.

If you have a legacy font, or if you only want to use a font for TeX and not have it cluttering up any of your other font lists, you can find your local TeX tree with the command

kpsewhich --var-value=TEXMFLOCAL

On Ubuntu (and, I believe, the MacOS console), you can have the shell look this up for you, with something like

export TEXMFLOCAL=$(kpsewhich --var-value=TEXMFLOCAL)

and then use commands such as cd $TEXMFLOCAL.

I would recommend you do something like creating the subdirectories $TEXMFLOCAL/emerald/fonts and $TEXMFLOCAL/emerald/tex, because this keeps all the files in this package together. TeX doesn’t care what subdirectory you put the files in. If you just mingle all the files from all your packages in the same tree, it’s impossible to uninstall cleanly, and you run the risk of some other package with fonts and tex folders overwriting its files.

Whenever you install a new font in your local tex tree, you want to run

sudo texhash
sudo updmap-sys --enable Map=emerald.map

to update the file database and the font maps. (If you have your own custom installation owned by an account named tex, this becomes sudo -u tex -E texhash, etc.)

In Beamer

Beamer defaults to using the sans-serif font. To get it to use Augie, you would want to \usefonttheme{serif}. You might also want to add the [professionalfonts] option to the \documentclass.

20
  • Thanks. The output of kpsewhich is "/usr/local/share/texmf". I have created a folder in texmf: emerald. "emerald" is the unzip folder of emerald.zip from CTAN. As a consequence, emerald has as subfolder: tex, fonts, other and doc. However when I run "sudo updmap-sys" I get some errors. (no error with "sudo texhash"): updmap [ERROR]: The following map file(s) couldn't be found: updmap [ERROR]: emerald.map (in /etc/texmf/web2c/updmap.cfg) updmap [ERROR]: Did you run mktexlsr? I think that I have to do something about map. What do you think?
    – diedro
    Apr 16, 2021 at 8:26
  • In the folder I have the new file "ls-R". This is the output of sudo texhash. The problem is sudo updmap-sys
    – diedro
    Apr 16, 2021 at 8:33
  • Ah, you might try, then, sudo updmap-sys --enable-map=emerald.map. You might need to give the absolute path, which you should be able to find (after running texhash) with kpsewhich emerald.map.
    – Davislor
    Apr 16, 2021 at 16:06
  • Unfortunately, I get the following error when I run sudo updmap-sys --enable-map=emerald.map: Unknown option: enable-map Try "updmap --help" for more information.
    – diedro
    Apr 16, 2021 at 21:15
  • @diedro Sorry, typo. Should've been sudo updmap-sys --enable Map=emerald.map. You might need the absolute path from kpsewhich emerald.map.
    – Davislor
    Apr 16, 2021 at 22:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .