2

There are many questions on \includesvg already, so

  • yes, I have added --shell-escape to latexmk, lualatexmk and pdflatex in .vscode\settings.json.

    Alternatively I have also put set_tex_cmds( '--shell-escape %O %S' ); in my .latexmkrc file.

  • yes, I have Inkscape in my %PATH% and I have restarted VS Code. In the VS Code terminal I get

     > inkscape --version
     Inkscape 1.0.2-2 (e86c870879, 2021-01-15)
     Pango version: 1.48.2
    
  • yes, I am not using an extension in \includesvg{xxx}.

Still, my \includesvg fails. The LaTeX compiler output says

Warning: Option --without-gui= is deprecated

Warning: Option --file= is deprecated

Warning: Option --export-pdf= is deprecated

Unknown Option -z

And somewhere in the log file I find similar stuff:

runsystem(inkscape -z -D --export-latex  --file="img/xxx.svg" --export-pdf="xxx_svg-tex.pdf" )...executed.

It seems to me as if I should change how runcommand() calls Inkscape. Where would I do that?

1
  • As always on the site please provide a full but minimal example that others can test. It would also be usefull to know which latex installation you're using.
    – daleif
    Commented Apr 15, 2021 at 13:29

1 Answer 1

1

I needed to ugrade from TexLive 2020 to TexLive 2021. It comes with a newer version of the svg package which calls Inkscape correctly and fixes bug 25.

2
  • Well, actually svg 2020/11/26 v2.02k is available with Tex Live 2020. You only would have to update via tlmgr update
    – mrpiggi
    Commented Apr 16, 2021 at 8:11
  • @mrpiggi I tried, but it said that cross version updates are not allowed. Maybe I did something wrong. Commented Apr 16, 2021 at 8:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .