1

I have using biblatex package and want to remove comma in the author. How to do this.

\usepackage[style=authoryear,citestyle=authoryear-ibid,sorting=nyt,dashed=false]{biblatex}

@ARTICLE{ipab730bbib2,
    author ={S F Edwards},
    year =1967,
    title ={Statistical mechanics with topological constraints: I},
    journaltitle ={Proc. Phys. Soc.},
    volume={91},
    pages={513},
}

I am expecting result is Edwards S F only. How to do this?

2

The punctuation between family and given name in family-given order is controlled by \revsdnamepunct, which defaults to a comma. If you don't want that comma, just redefine \revsdnamepunct to be empty.

\documentclass[british]{article}
\usepackage[T1]{fontenc}
\usepackage{babel}
\usepackage{csquotes}

\usepackage[
  style=authoryear-ibid,
  dashed=false,
  terseinits, giveninits
]{biblatex}

\renewcommand*{\revsdnamepunct}{}

\begin{filecontents}{\jobname.bib}
@ARTICLE{ipab730bbib2,
  author       = {S. F. Edwards},
  year         = 1967,
  title        = {Statistical Mechanics With Topological Constraints: I},
  journaltitle = {Proc. Phys. Soc.},
  volume       = {91},
  pages        = {513},
}
\end{filecontents}
\addbibresource{\jobname.bib}
\addbibresource{biblatex-examples.bib}

\begin{document}
Lorem \autocite{sigfridsson,ipab730bbib2}

\printbibliography
\end{document}

Edwards SF (1967). ‘Statistical Mechanics With Topological Constraints: I’. In: Proc. Phys. Soc. 91, p. 513.


If you want to retain the space between the initials and only want no dots, remove the terseinits option and add

\renewrobustcmd*{\bibinitperiod}{}

to the preamble.

\documentclass[british]{article}
\usepackage[T1]{fontenc}
\usepackage{babel}
\usepackage{csquotes}

\usepackage[
  style=authoryear-ibid,
  dashed=false,
  giveninits
]{biblatex}

\renewcommand*{\revsdnamepunct}{}
\renewrobustcmd*{\bibinitperiod}{}

\begin{filecontents}{\jobname.bib}
@ARTICLE{ipab730bbib2,
  author       = {S. F. Edwards},
  year         = 1967,
  title        = {Statistical Mechanics With Topological Constraints: I},
  journaltitle = {Proc. Phys. Soc.},
  volume       = {91},
  pages        = {513},
}
\end{filecontents}
\addbibresource{\jobname.bib}
\addbibresource{biblatex-examples.bib}

\begin{document}
Lorem \autocite{sigfridsson,ipab730bbib2}

\printbibliography
\end{document}

Edwards S F (1967). ‘Statistical Mechanics With Topological Constraints: I’. In: Proc. Phys. Soc. 91, p. 513.

8
  • It's working fine. But space is missing. It should be Edwards S F. In the bib file space is found but output space is missing. How to get with space?
    – Balaji
    Apr 17 at 11:01
  • @Balaji Oh, sorry I thought you wanted to remove the space. The question said Edwards SF.
    – moewe
    Apr 17 at 11:02
  • I am sorry and modified the question now.
    – Balaji
    Apr 17 at 11:04
  • @Balaji I see. Have a look at the edit, please.
    – moewe
    Apr 17 at 11:05
  • But in the end of the initials comma is present. Edwards S F, it should be Edwards S F. How can modify this?
    – Balaji
    Apr 17 at 11:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.