\bibliographystyle doesn't seem to be applied.
I want to get

Майоров С.А., Новиков Г.И. Принципы организации цифровых машин. - Л.: Машиностроение, 1974. - 432 с.

but I'm getting

Новиков Г.И. Майоров С.А. Принципы организации цифровых машин. Машиностроение, Л., 1974.


Style used to format as showed on the first example is in gost71u.bst file. I even tried to copy this file to directory where .tex file located. Here is the code



    % blah blah

    \addcontentsline{toc}{section}{Список литературы}
    \renewcommand{\bibname}{Список литературы}


Also there are some extra styles: gost780s, gost71s, gost780u, but they are not applying too.

I'm using the sequence of commands described there: at first I'm running pdflatex and then — bibtex. And it worked only once.

  • 1
    Does it help if you remove the initial \bibliographystyle{unsrt} statement?
    – Mico
    Jun 11, 2012 at 1:11
  • it would probably be helpful if you included the .bib input with your question. Jun 11, 2012 at 12:40

1 Answer 1


I updated my latex packages and found that there are no gost71* files (but don't know why it didn't work before update). There are new standards which should be used with gost2003* and gost2008* styles.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .