1

I use this code block to declare the bibliography style of my article. The result for most of my in-text citations looks as expected (authoryear citation), however, some citations include the first names or more authors than needed (e.g., J. V. Smith, Williams, and Hall, 2020). I am using the \citep{}and \textcite{} commands.

Moreover, the sorting of my bibliography is not consistently in the style author year even though I am using sorting=nyt.

%%% Bibliography
\usepackage[
    style=apa,
    backend=biber,
    bibencoding=utf8,
    bibwarn=false,
    isbn=false,
    url=true,
    doi=false,
    eprint=false,
    giveninits=true,
    natbib=true,
    maxbibnames=99,
]{biblatex}
\DeclareNameAlias{author}{family-given}
\DeclareNameAlias{editor}{family-given}
\DeclareNameAlias{translator}{family-given}
\addbibresource{references.bib}     

Some example entries:

@article{vandenBroeke.2009,
 author = {{van den Broeke}, Michiel and Bamber, Jonathan and Ettema, Janneke and Rignot, Eric and Schrama, Ernst and {van de Berg}, Willem Jan and {van Meijgaard}, Erik and Velicogna, Isabella and Wouters, Bert},
 year = {2009},
 title = {Partitioning recent Greenland mass loss},
 pages = {984--986},
 pagination = {page},
 volume = {326},
 journaltitle = {Science (New York, N.Y.)},
 language = {eng},
 doi = {10.1126/science.1178176},
 number = {5955},
}


@article{vandenBroeke.2008,
 author = {{van den Broeke}, Michiel and Smeets, Paul and Ettema, Janneke and Munneke, Peter Kuipers},
 year = {2008},
 title = {Surface radiation balance in the ablation zone of the west Greenland ice sheet},
 keywords = {Greenland;observations;radiation balance},
 volume = {113},
 issn = {0148-0227},
 journaltitle = {Journal of Geophysical Research},
 shortjournal = {J. Geophys. Res.},
 doi = {10.1029/2007JD009283},
 number = {D13},
}

@article{vandenBroeke.2016,
 author = {{van den Broeke}, Michiel R. and Enderlin, Ellyn M. and Howat, Ian M. and {Kuipers Munneke}, Peter and No{\"e}l, Brice P. Y. and {van de Berg}, Willem Jan and {van Meijgaard}, Erik and Wouters, Bert},
 year = {2016},
 title = {On the recent contribution of the Greenland ice sheet to sea level change},
 pages = {1933--1946},
 pagination = {page},
 volume = {10},
 journaltitle = {The Cryosphere},
 doi = {10.5194/tc-10-1933-2016},
 number = {5},
 abstract = {}
}

I would like to have them sorted in the order after the last name of the first author and whenever multiple entries for the same author are available after the year. In case of my example:

  1. van den Broeke 2008
  2. van den Broeke 2009
  3. van den Broeke 2016

Does anybody know how to solve these problems?

5
  • The sorting is impossible to debug without example entries and an explanation of which order would be expected.
    – moewe
    Apr 26 at 7:35
  • The other observations are due to the uniquename and uniquelist options. See tex.stackexchange.com/q/69028/35864 and tex.stackexchange.com/q/134535/35864 and the documentation for more in-depth explanation.
    – moewe
    Apr 26 at 7:35
  • 1
    Your style setup is a bit odd. First you have style=authoryear, and then you overwrite just the bibliography style (but not the citation style) with bibstyle=apa,. It is APA style to set uniquename and uniquelist to the values you are currently seeing. But biblatex-apa is not supposed to be used together with a different citation style, it should be used as style=apa,. Note that biblatex-apa comes with its own sorting scheme and so setting sorting=nyt, is counter-productive if you want APA style.
    – moewe
    Apr 26 at 7:37
  • @moewe Thank you very much for your advice! Adding uniquename and uniquelist to my preamble solved the first issue.
    – user240690
    Apr 26 at 8:16
  • @moewe I added some more detail to my sorting question above. However, after deleting style=authoryear and sorting=nyt the order is still not as expected.
    – user240690
    Apr 26 at 11:24
2

The behaviour you are seeing is correct APA style, which you requested with biblatex-apa's style=apa,.

If you do not want to follow proper APA style it is usually much better to start from one of the standard styles (e.g. style=authoryear, or style=authoryear-comp,) than to mess with style=apa,.

As already mentioned in the comments you are seeing the effect of the uniquelist and uniquename options. biblatex can try to avoid ambiguous "et al." truncations and can add given name initials to disambiguate different authors with the same family name (this includes cases where the same author is cited with slight variations in their name). See Set limit to one author when using "et al." in biblatex and biblatex, authoryear style: In-text citations display first name initials for certain bibliography entries for additional detail. In the MWE below both features are turned off (but that means that you are no longer APA compliant).

The standard sorting scheme takes all names that are visible in the bibliography into account when sorting the bibliography entries. So vandenBroeke.2009 is sorted before vandenBroeke.2008 because the second author of vandenBroeke.2009 is Jonathan Bamber, who sorts before vandenBroeke.2008's Paul Smeets. You can tell biblatex to ignore some names by playing around with the minsortnames and maxsortnames options (the rules are as follows: a list exceeding maxsortnames names is shortened to minsortnames names, so with minsortnames=1, maxsortnames=3, lists of four or more authors sort only by the first author).

\documentclass[american]{article}
\usepackage[T1]{fontenc}
\usepackage{babel}
\usepackage{csquotes}

\usepackage[backend=biber,
  style=apa,
  minsortnames=1, maxsortnames=3,
  uniquelist=false, uniquename=false
]{biblatex}

\begin{filecontents}{\jobname.bib}
@article{vandenBroeke.2009,
 author       = {van den Broeke, Michiel and Bamber, Jonathan
                 and Ettema, Janneke and Rignot, Eric and Schrama, Ernst
                 and van de Berg, Willem Jan and van Meijgaard, Erik
                 and Velicogna, Isabella and Wouters, Bert},
 year         = {2009},
 title        = {Partitioning Recent {Greenland} Mass Loss},
 pages        = {984--986},
 pagination   = {page},
 volume       = {326},
 journaltitle = {Science (New York, N.Y.)},
 language     = {eng},
 doi          = {10.1126/science.1178176},
 number       = {5955},
}
@article{vandenBroeke.2008,
 author       = {van den Broeke, Michiel and Smeets, Paul
                 and Ettema, Janneke and Kuipers Munneke, Peter},
 year         = {2008},
 title        = {Surface Radiation Balance in the Ablation Zone
                 of the West {Greenland} Ice Sheet},
 keywords     = {Greenland;observations;radiation balance},
 volume       = {113},
 issn         = {0148-0227},
 journaltitle = {Journal of Geophysical Research},
 shortjournal = {J. Geophys. Res.},
 doi          = {10.1029/2007JD009283},
 number       = {D13},
}
@article{vandenBroeke.2016,
 author       = {van den Broeke, Michiel R. and Enderlin, Ellyn M.
                 and Howat, Ian M. and Kuipers Munneke, Peter
                 and Noël, Brice P. Y. and van de Berg, Willem Jan
                 and van Meijgaard, Erik and Wouters, Bert},
 year         = {2016},
 title        = {On the Recent Contribution of the
                 {Greenland} Ice Sheet to Sea Level Change},
 pages        = {1933--1946},
 pagination   = {page},
 volume       = {10},
 journaltitle = {The Cryosphere},
 doi          = {10.5194/tc-10-1933-2016},
 number       = {5},
}
\end{filecontents}
\addbibresource{\jobname.bib}
\addbibresource{biblatex-examples.bib}

\begin{document}
Lorem \autocite{sigfridsson,vandenBroeke.2009,vandenBroeke.2008,vandenBroeke.2016}

\printbibliography
\end{document}

Sigfridsson, E., & Ryde, U. (1998).//van den Broeke, M., Smeets, P., Ettema, J., & Munneke, P. K. (2008).//van den Broeke, M., Bamber, J., Ettema, J., Rignot, E., Schrama, E., van de Berg, W. J., van Meijgaard, E., Velicogna, I., & Wouters, B.//van den Broeke, M. R., Enderlin, E. M., Howat, I. M., Kuipers Munneke, P., Noël, B. P. Y., van de Berg, W. J., van Meijgaard, E., & Wouters, B.

1
  • Thank you very much for your very detailed answer! This solved all of the problems mentioned!
    – user240690
    Apr 27 at 7:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.