0

I was trying to draw a switching circuit using circuitikz package. But I got an error that circuitikz.sty file is missing. Then I tried to update MiKTeX Console having an idea how to install packages from here. Following this, I received another error that 'A connection to ims.jit.ac.in could not be established. More info: miktex.org/kb/fix-couldnt-connect'. Then I uninstalled the MiKTeX (version most probably 2.9) and reinstalled the newest (version 20.12). Now I am getting the error : File `amsthm.sty' not found. \usepackage.

Everytime I go for an update, whether it's miktex update or any package update, I get 'SSL connect error' and the copy error button gives me:

'GENERAL MIKTEX INFORMATION ReportDate: 2021-04-27 04:33:38 CurrentVersion: 21.2 SetupDate: 2021-04-27 03:46:00 SetupVersion: 21.2 Configuration: Regular GitInfo: 7a7e645 / 2021-02-20 10:38:14 OS: Windows 7 Ultimate, 64-bit, Service Pack 1, build 7601 SharedSetup: no LinkTargetDirectory: C:\Users\MANJOY\AppData\Local\Programs\MiKTeX\miktex\bin\x64 PathOkay: yes LastUpdateCheck: not yet LastUpdate: not yet LastUpdateDb: not yet SystemAdmin: yes RootPrivileges: no AdminMode: no Root0: C:\Users\MANJOY\AppData\Roaming\MiKTeX Root1: C:\Users\MANJOY\AppData\Local\MiKTeX Root2: C:\Users\MANJOY\AppData\Local\Programs\MiKTeX Root3: C:\ProgramData\MiKTeX Root4: C:\Program Files\MiKTeX UserInstall: C:\Users\MANJOY\AppData\Local\Programs\MiKTeX UserConfig: C:\Users\MANJOY\AppData\Roaming\MiKTeX UserData: C:\Users\MANJOY\AppData\Local\MiKTeX CommonInstall: C:\Program Files\MiKTeX CommonConfig: C:\ProgramData\MiKTeX CommonData: C:\ProgramData\MiKTeX Invokers: .../RdrCEF/RdrCEF/explorer The following issues were detected: 1: major issue: So far, you have not checked for MiKTeX updates. ERROR DETAILS Program: C:\Users\MANJOY\AppData\Local\Programs\MiKTeX\miktex\bin\x64\miktex-console.exe Source: Libraries\MiKTeX\PackageManager\CurlWebSession.cpp:247 Error: SSL connect error Details: code: 35 url: https://ims.jit.ac.in/repo/tex-archive/systems/win32/miktex/tm/packages/circuitikz.tar.lzma'

Note: I am also not able to check update for the new MiKTeX version.

4
  • 1
    Seems the repo you are trying to connect to is down (currently ims.jit.ac.in/repo/tex-archive shows that it is unavailable). Try changing the repository/mirror to a different site tex.stackexchange.com/questions/56783/… – Willie Wong Apr 27 at 2:57
  • @WillieWong I changed the package source by setting a proxy. Since ims.jit.ac.in was not working, i chose mirrors.sustech.edu.cn from China. Will it cause any legal issue? – Manjoy Das Apr 27 at 9:06
  • IANAL, but all repositories listed at miktex.org/pkg/repositories should be publicly available. – Willie Wong Apr 27 at 13:12
  • @WillieWong after choosing the above proxy, when I set back to random package repository on the internet, again the error message is popping up which means that the problem is not solved completely. Would you like to suggest something for that? – Manjoy Das Apr 27 at 15:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.