0

Initially the issue was circuitikz.sty was missing. Then I tried to update package from MiKTeX console package option and I got the error

SSL connect error

and the code was

code="35", url="https://ims.jit.ac.in/repo/tex-archive/systems/win32/miktex/tm/packages/miktex-zzdb1-2.9.tar.lzma"

Then I uninstalled MiKTeX and reinstalled it. After that MiKTeX console is not updating and doesn't let any package to be updated. When I try to check update for console, it shows
enter image description here

When I try to update packages, it shows:
enter image description here

Also the Texstudio has stopped the compilation. This is becoming a notorious problem for my purpose. Any sort of suggestion is welcome!

3
  • If there are connection problems it seldom helps to deinstall and reinstall MiKTeX as the new MiKTeX will have the same connection problem. And it can make the situation worse as the new version hasn't all the packages and updates you installed already. – Ulrike Fischer Apr 27 at 6:02
  • @UlrikeFischer I changed the package source by setting a proxy. Since ims.jit.ac.in was not working, i chose mirrors.sustech.edu.cn from China. Will it cause any legal issue? – Manjoy Das Apr 27 at 9:01
  • Sorry I have no idea. – Ulrike Fischer Apr 27 at 9:03
0

It appears the site https://ims.jit.ac.in/repo/tex-archive is having some issues. You can change the repository that MikTeX updates from by following the instructions at How can I change the package repository?

1
  • Yours and Ulrike's answers are quite right. I replied on Ulrike's comment. Please serve your suggestions too. – Manjoy Das Apr 27 at 9:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.