I am quite confused that I cannot find any information on this topic as I do not think I'm the only one affected. Using TeXnicCenter, I recently upgraded to a 4k screen. While making my life significantly brighter, all the icons and the text appears way too small in the editor. I know that the text itself can be re-sized using ctrl + mouse wheel. However, this larger text looks ugly and unfamiliar. I am using the screen as an add-on to my (FHD) notebook. Trying to use the Windows-setting to scale the entire screen did not work (well, it does for everything but TXC). Is there any solution to this issue? It's pretty annoying.

  • I don't see how changing the font size makes the text ugly, unless the default font always looks ugly but you don't usually notice it. May 3, 2021 at 12:22
  • I hope that you'll find a workaround, but keep in mind that TeXnic Center is a dead project. The last version was released 10 years ago, so the authors never did the necessary work to support high DPI monitors (which your new 4K monitor presumably is).
    – Miyase
    Feb 23 at 11:26

1 Answer 1


I had the same issue when switched to a 4K monitor. I was able to properly fix the text issue as follows: In the main menu, go to: Tools > Options > Text Format. In top window you can select from : Editor / Navigator / Output and then click on the button 'Choose' to chose the font type and size. Then click 'OK' and allow for a few seconds for the change to be reflected on the GUI.

As to the menu icons, I couldn't find any good alternative, as the route : Tools > Customize > Options and ticking the 'Large Icon' option result in a ugly pixelized big icons (maybe a restart is needed, but I didn't bother to try).

Hope this helps.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .