I was hoping \FloatBarrier could place my image where I want it to be and wrap text around it, but the second column is not getting filled. Also I have been trying hard to put the image just below the Methodology. How do I enable filling the second column with text and place the image below the methodology?

enter image description here


The framework for this study is visualized in Figure~1 and described in detail below.

    \caption{MGWR Process.}

\subsection{Study Area}\label{sec:StudyArea}
The study area is shown in Figure~2. The NCR Plus bubble is a location in the Philippines that consists of the National Capital Region and four neighbor provinces namely Bulacan, Cavity, Laguna and Rizal. On March 22, 2021, the bubble setup was placed in a “Enhanced Community Quarantine” because of rising COVID-19 cases. A total of 108 sample points, representing each municipality and city, were used for MGWR analysis. These points are the centroids for each municipality and city inside the bubble since the reported COVID-19 cases were aggregated in a municipal and city level.


After using dblfloatfix, the image went too far and sort of find a location to fit in a bottom [b]. How can I force it to be placed just under where I want it to be -- methodology part? enter image description here


Removed \FloatBarrier, but my image still too far where it is referenced.

  • 2
    floatbarrier will force a page break which is what you are trying to avoid. By default latex does not support bottom spanning flotas so the b option is ignored, use packages such as dblfloatfix to allow the float at bottom of page Commented May 3, 2021 at 15:10
  • Thanks! However it went too far to my document (not the end of the document now). Its not yet under the methodology. How can I force that?
    – Nikko
    Commented May 3, 2021 at 15:19
  • I updated my question for the image...
    – Nikko
    Commented May 3, 2021 at 15:21
  • 2
    you haven't provided an example anyone can run so we can only give hints, You need to remove \FloatBarrier as that will prevent teh outcome you want, an ddouble column figures always come at the earliest on the next page, so move it earlier in the source file. Commented May 3, 2021 at 15:39
  • 1
    you haven't removed it from the code shown here, that is the code that you are asking about. There is nothing wrong with the [bp] option you simply need to move the environment earlier in the source so it comes on the page that you want. Commented May 3, 2021 at 16:02

1 Answer 1


You need a package such as dblfloatfix to alow figure* to be placed at the bottom, an ddouble column floats appear at the earliest on the next page, so to foce it to appear on the page that you want, you may need to place it earlier in the source so that it is in the queue to be added when the page starts.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .