I just updated my MiKTeX and now nor latex, neither pdflatex not compiling my tex. Even if it contains only


No error messages are shown, no files are created. It just hangs.

  • 1
    difficult to tell what is going on. Do you use a special class? maybe you downloaded miktex basic only and there are packages missing? If you use TenicCenter as editor, make sure you have "install missing packgaes on the fly" set to "yes" and not "ask me first" in the miktex settings. did you try compiling from the command line?
    – Martin H
    Commented Jun 12, 2012 at 12:48
  • @MartinH It worked well about a hour ago. Now it doesn't work even in the command line. The only output I have is "C:\Users\efpies>pdflatex -synctex=1 -interaction=nonstopmode "D:\Dropbox\Publicuniversity\Diplom\report.tex" This is pdfTeX, Version 3.1415926-2.4-1.40.13 (MiKTeX 2.9)"
    – efpies
    Commented Jun 12, 2012 at 12:52
  • Delete the temporary files like aux toc etc. (clean project). It is generally not a good idea to sync within drop box (afaik). I think I read something some time ago that this may cause file version problems due to the radiply changing file versions...This may not be true however, I never tested it myself.
    – Martin H
    Commented Jun 12, 2012 at 12:57
  • 1
    I just updated on my netbook (winxp) and it works fine. But as the binaries have been updated the formats must be regenerated. Miktex triggers the format generation when you use pdflatex the first time. Perhaps this fails and so pdflatex hangs. Try to build the format through miktex settings to check if there are errors. Commented Jun 12, 2012 at 13:38
  • 2
    There is on the tab "General" a button "update Formats" which will update all formats and there is a tab "Formats" with a button "build" which you can click as soon as you have choosen a format from the list. It will build a specific format. Use this for the first test. Commented Jun 12, 2012 at 14:07

3 Answers 3


Based on the comments to your question, I think you will have to completely remove Miktex and reinstall it.

  • 3
    No. Before doing something drastic one should always have at least a vage idea what is the problem. If e.g. it is due to some broken exotic language file reinstalling everything will not help but the problem can be easily solved by removing the language from language.dat. Commented Jun 12, 2012 at 14:14
  • 1
    Reinstalling Miktex requires very little (manual) work and is surely worth trying rather early.
    – Ben
    Commented Jun 12, 2012 at 14:29
  • 2
    I just installed miktex on a new PC and it took about 2 hours until everything was downloaded and installed. And it was a new installation - I hadn't to remove an older version and make backups first. I won't recommend someone to do this unless I have a rather clear idea that it will help. Commented Jun 12, 2012 at 14:47
  • 14
    @efpies: You shouldn't run updates if you have a deadline. Commented Jun 12, 2012 at 14:48
  • 2
    UlrikeFischer: I said it required little manual work. It will take some time for the computer, that is of course true. Also, updating Miktex days before a deadline is just too brave.
    – Ben
    Commented Jun 12, 2012 at 15:57

I had to delete my *.aux file and there was a *.synctex(busy) file which I also deleted. Then I could compile again.


What worked for me on Windows 7:

  1. Reboot.

  2. Install all latest MiKTeX updates:

    Screenshot of start menu with entry "Update"

  3. Reboot.

  4. Refresh FNDB (file name database) using MikTeX Options:

    Screenshot of start menu with entry "Settings"
    Screenshot of window "Options"

    During this step, additional packages were installed.

The reboots were done because, after testing, there were issues with processes locking files.

Possibly related: On my system I got an error message about a missing QT5 DLL, which I solved by installing package: miktex-qt5-bin

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .